Connect with us

Star XL 4600DL

Discussion in 'Troubleshooting and Repair' started by Alan Kurinovich, Aug 2, 2009.

Scroll to continue with content
  1. Alan Kurinovich

    Alan Kurinovich

    1
    0
    Aug 2, 2009
    I have a Star XL 4600DL. Recently for no reason, I could not enter my password to activate the alarm system. Each time I entered a number it did not ping. I tried all three keypads in my house with the same result. The AC, Ready & Automatic indicator lights are on. According to the manual I tested the battery by removing the AC plug and I tried to enter my password which failed I mentioned above. I reconnected the AC plug and still there was no change. If I purchase a new battery will this solve my problem or is there something else I should be trying?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-