Connect with us

Amico MTS-185 multi-process welder no start

Discussion in 'Troubleshooting and Repair' started by Raylicker, Oct 16, 2019.

Scroll to continue with content
  1. Raylicker

    Raylicker

    9
    0
    Oct 16, 2019
    Hi all, do you or could you lead me to a group that can help me get this welder going. I left it on for about an hour and when I got back it was off and never to start again. The power light goes on but nothing else. The switch is good. Only had the thing for 1 year and one month after the warranty expired. Thanks you for any help here or point me to another group, I was told there was one that would help with troubleshoot boards
     
  2. Bluejets

    Bluejets

    4,095
    859
    Oct 5, 2014
    Just to be clear, warranty expired 13 months before fault occurred or 1 month before...??
    If the latter I'm sure an approach to the manufacturer would be worth the effort.

    Other than that, one could check fuses or any visible signs of failure.
    Just be wary of internal high voltages and charged capacitors.
    These things are internally quite complex with very little data available.
     
  3. Raylicker

    Raylicker

    9
    0
    Oct 16, 2019
    I'm getting power to the capacitors but don't know where o check after that. Here are pics of the two boards in it. Could it be on the little board? if I am getting power all the way to the capacitors, shouldn't I have front panel lights or something? Please any help, here are pics of both boards
     
  4. 73's de Edd

    73's de Edd

    2,888
    1,224
    Aug 21, 2015
    Your board pics, fell off the wagon, on the way here.
     
  5. Raylicker

    Raylicker

    9
    0
    Oct 16, 2019
    It won't let me upload pics, why?
     
  6. 73's de Edd

    73's de Edd

    2,888
    1,224
    Aug 21, 2015
    Assuredly, because of it requiring too high of a storage density. Seems like the limit here is 100's of K's.
    If such is the case you either reconfigure them as J-pegs to see if the then lowered density will be accepted.
    Or you. can keep them as png's and find a site akin to bbimage and upload them for that site to host for you.
    Then they will assign a sub URL to them, for you to use and copy into the message text at this site.
    Then you immediately click on the image icon ,being at the top of the page, whereupon , a dialog box will drop down and request that sub URL again , then it accepts and disappears and you then continue on with your message.

    Thaaaaaaaasssssssit.

    73's de Edd . . . .
     
    Last edited: Oct 28, 2019
  7. Raylicker

    Raylicker

    9
    0
    Oct 16, 2019

    Here are the pics
     

    Attached Files:

Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-