Connect with us

MPLAB error message

Discussion in 'Electronic Design' started by kansas_ray, Jan 8, 2004.

Scroll to continue with content
  1. kansas_ray

    kansas_ray Guest

    Hi to all,

    I am running MPLAB software to a PIC16F877A microcontroller via a CCS
    ICD-S20 pod. After downloading the code I get a pop-up with the following
    error message:

    "Could not start the target. The target was not halted after reset. Check
    the target oscillator and MCLR."

    I am using a 20MHz crystal oscillator from EPSON (working fine). The MCLR
    circuit is an MCP120-4.5V pulled up to 5V with 4.7K, diode-isolated with a
    BAT54 diode, pulled down to GND with 47K, then connected to MCLR and the ISP
    connector. PGB, PGC, and PGM are connected only to the ISP connector.

    The code actually downloads and runs but I can't breakpoint.

    Any inputs are most welcome,
    Ray
     
  2. [failed PIC]

    I've had the oscillator on a PIC12F675 fail after a static hit. It still
    downloaded and verified, it just didn't 'go'. I tried an external
    oscillator, same thing. When I tried another chip, it worked properly.

    Those are cheap chips, so I just tossed it and moved on.

    Regards,
    Bob Monsen
     
  3. kansas_ray

    kansas_ray Guest

    I'm sorry for my delayed response.

    We have the same problem on four different designs all using the same PIC.
    I'm told there may be a software incompatibility between MPLAB and the ICD
    but I don't know which versions should work and I'm not on the update
    program with CCS.

    I guess we'll work around it using a serial stream output to communicate
    status. A friend of mine tells me he hasn't used a breakpoint with the CCS
    in years.

    Regards,
    Ray
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-