Realistic STA-2100D

Discussion in 'Audio' started by tomcat65, Jun 23, 2018.

  1. tomcat65

    tomcat65

    Joined:
    Jun 23, 2018
    Messages:
    24
    Likes Received:
    0
    I think it has something to do with the output boards.I l also found one blown output transistor and have pulled both right and left output boards.One Checks out good the other one has some of the transistors are not reading the same as on the good board.
     
    tomcat65, Jul 5, 2018
    #21
  2. tomcat65

    tomcat65

    Joined:
    Jun 23, 2018
    Messages:
    24
    Likes Received:
    0
    Well,I disconnected both amplifier output boards,unplugging the main power supply capacitors on both channels.Turned the receiver on with my bulb dimmer.Everything lit up,Heard one relay click and the power button went from red to green.If I power off and connect either power board in,unit powers on with lights but stays in protect mode.Not sure where to start looking!Anyone have some suggestions?Output transistors test good on both channels.
     
    tomcat65, Jul 7, 2018
    #22
  3. tomcat65

    tomcat65

    Joined:
    Jun 23, 2018
    Messages:
    24
    Likes Received:
    0
    Anyone know where I can obtain a volume balance part like this one for a STA-2100D receiver?This one is no good.Thanks!
     

    Attached Files:

    tomcat65, Jul 13, 2018
    #23
  4. tomcat65

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    Joined:
    Jan 21, 2010
    Messages:
    24,757
    Likes Received:
    2,538
    Location:
    Mid way between Beijing and the Ronne Ice Shelf
    That part is likely to be almost pure unobtainium.

    What's wrong with it?
     
    (*steve*), Jul 13, 2018
    #24
  5. tomcat65

    tomcat65

    Joined:
    Jun 23, 2018
    Messages:
    24
    Likes Received:
    0
    The volume part and the balance part turn together.Like they were welded together.Cannot separate them
     
    tomcat65, Jul 13, 2018
    #25
  6. tomcat65

    73's de Edd

    Joined:
    Aug 21, 2015
    Messages:
    2,416
    Likes Received:
    808
    Location:
    Texas
    Sir tomcat65 . . . . .

    The volume and balance control are supposed to be "clutched" together.
    You bring up the volume knob up to a high enough mono source evaluative level and then adjust the separate balance where both speaker channels then equate in level .
    Thereafterwards, as the volume adjustment is changed, the balance remains in tracking at all volume levels.

    *** Since you now have the naked control bank . . . . install the two knobs so that you will have some "torque amplification " and then HOLD hold the volume knob immobile and then see if the separate balance knob can then be adjusted . . .in either direction . . .between its full ~270 degree range.
    Then you will see that the balance setting will be retained as both controls rotate simultaneously, when only the volume control is rotated.
    OR . . . but I have never seen it happen . . . .that internal contamination has actually physically locked the two controls rotation capabilities together and the *** operation above cannot be achieved.

    Next we go back to the drawing board / schematic, if the control is actually normally clutched /tracking.

    73's de Edd
     
    73's de Edd, Jul 13, 2018
    #26
  7. tomcat65

    tomcat65

    Joined:
    Jun 23, 2018
    Messages:
    24
    Likes Received:
    0
    When I put the balance control knob on and held the volume control with pliers,balance knob will not move.Not sure what has happened but no longer works.
     

    Attached Files:

    tomcat65, Jul 13, 2018
    #27
  8. tomcat65

    Externet

    Joined:
    Aug 24, 2009
    Messages:
    623
    Likes Received:
    131
    Location:
    Mideast US
    Check if the shafts engage/disengage clutch by pulling or pushing one relative to the other.
    And treat that control with love, may not be replaceable. Holding with pliers may deform its barrel and bind.
     
    Last edited: Jul 14, 2018
    Externet, Jul 14, 2018
    #28
  9. tomcat65

    tomcat65

    Joined:
    Jun 23, 2018
    Messages:
    24
    Likes Received:
    0
    Ok thanks
     
    tomcat65, Jul 14, 2018
    #29
  10. tomcat65

    tomcat65

    Joined:
    Jun 23, 2018
    Messages:
    24
    Likes Received:
    0
    What does it mean when my sta-2100D receiver running off dimmer bulb,at low volume,the bulb is barely lit.As I turn up the volume,the light gets brighter!!Any thoughts?
     
    tomcat65, Jul 15, 2018
    #30
  11. tomcat65

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    Joined:
    Jan 21, 2010
    Messages:
    24,757
    Likes Received:
    2,538
    Location:
    Mid way between Beijing and the Ronne Ice Shelf
    That's pretty much what you expect to happen.
     
    (*steve*), Jul 15, 2018
    #31
  12. tomcat65

    tomcat65

    Joined:
    Jun 23, 2018
    Messages:
    24
    Likes Received:
    0
    Ok,thanks!
     
    tomcat65, Jul 15, 2018
    #32
  13. tomcat65

    tomcat65

    Joined:
    Jun 23, 2018
    Messages:
    24
    Likes Received:
    0
    When one channel is out,can there still be a. Problem with the power supply or is it more probable to be that amps output board?There has to be something wrong somewhere,as the minute I connect up the left channel board,I hear the protection relay.
     
    tomcat65, Jul 18, 2018
    #33
  14. tomcat65

    tomcat65

    Joined:
    Jun 23, 2018
    Messages:
    24
    Likes Received:
    0
    Hello.Anyone know where I can purchase a new 24 VDC speaker relay unit for a Realistic sta -2100D receiver?The one in there now is buzzing and cutting out the left speaker output.It says type MS-40 24 VDC on the plastic cover followed by DEO 029 Japan.I believe it has 8 pins,2 rows of four pins and 2 solder connections above the 2 rows of pins.Any help would be greatly appreciated!!!!
     
    tomcat65, Jul 27, 2018
    #34
  15. tomcat65

    daddy60

    Joined:
    Nov 8, 2018
    Messages:
    4
    Likes Received:
    1
    Mouser has one that works. MY4-02 dc24 Omron automation
     
    daddy60, Nov 8, 2018
    #35
  16. tomcat65

    daddy60

    Joined:
    Nov 8, 2018
    Messages:
    4
    Likes Received:
    1
    The 2100 turns on with A relay working. Power light goes to green. No audio output.
    I checked the transformer, large filter caps, full wave bridge rectifier, and these were all in working order. I checked the transistors around the B relay. All appeared to be ok. B relay does not activate with the delay after A relay. I see no need to check the dc balance or idling current at this time. Which transistors on power board or protection board might be bad? All fuses are ok. I need help please. Tr601 and Tr604 act funny when I check collector to emitter and collector to base. Could it be the bridge rectifier on the power board? there are only 4 transistors on the power board but, I have not tested these yet. I know I sound like I am kind of nuts but this thing has driven me there. I have another one that does not power up either. But it does not come on at all. I checked the transformer on this one and it was ok. I really need help with the first one.

    Does anyone have suggestions on which capacitors (audio grade) would be best on the power board, preamp, and amp boards? I looked at nichicon but I am not sure which one to use where. the unit is fairly clean and I am getting ready to give it the works for cleaning.
    thank you.
     
    daddy60, Nov 8, 2018
    #36
  17. tomcat65

    kellys_eye

    Joined:
    Jun 25, 2010
    Messages:
    4,159
    Likes Received:
    1,112
    Location:
    West Coast, Scotland
    'Act funny' isn't a technical term I recognise.

    References to part numbers isn't very useful when we don't have a schematic to compare to.

    Post the schematic and any pictures of the circuit boards you have.
     
    kellys_eye, Nov 8, 2018
    #37
  18. tomcat65

    daddy60

    Joined:
    Nov 8, 2018
    Messages:
    4
    Likes Received:
    1
    I am talking ABOUT THE 2100 NOT THE 2100D
    WORKING ON GETTING THE FILE. IT IS TOO LARGE. I AM TRYING TO FIND A WAY TO MAKE IT SMALLER. I WILL SEND PICTURES.
     
    daddy60, Nov 9, 2018
    #38
  19. tomcat65

    Ylli

    Joined:
    Jun 19, 2018
    Messages:
    91
    Likes Received:
    17
    Service manual available at https://elektrotanya.com/realistic_sta-2100_sm.pdf/download.html.

    Relay "A" = relay associated with TR1301, the soft start board?
    Relay "B" = relay associated with TR601 connecting the audio outputs to the speaker terminals?

    Are you sure relay "B" is not pulling in? With power on, what is the voltage on terminal 1 of the protect board? (This is the junction of D601/C601/TR606-E)
     
    Ylli, Nov 9, 2018
    #39
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
Loading...