Keithley 600B input mosfets

Discussion in 'Electronics Repair' started by (*steve*), Jan 3, 2017.

  1. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    Joined:
    Jan 21, 2010
    Messages:
    23,010
    Likes Received:
    2,032
    Location:
    Mid way between Beijing and the Ronne Ice Shelf
    I started fixing up a Keithley 600B electrometer over the weekend.

    The problem I'm having at the moment is that the input stage is rather suspect.

    The device is essentially an OP-AMP made with discrete components. It allows measurement of extremely low currents, and very high resistances.

    The input is a matched pair of MOSFETs with zener protection of the exposed gate (which essentially is the input terminal)

    Given the extremes of currents and resistances, the input has lots of Teflon standoffs, cables, etc.

    I've found a few references to possible replacements, but the construction may be the biggest challenge if I am to retain the original specs.

    I'll provide more links and photos later...
     
    (*steve*), Jan 3, 2017
    #1
    1. Advertisements

  2. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    Joined:
    Jan 21, 2010
    Messages:
    23,010
    Likes Received:
    2,032
    Location:
    Mid way between Beijing and the Ronne Ice Shelf
    Some of the stuff I did during the weekend was to clean up the battery compartment (the foam had badly deteriorated) and to replace the 1.35V murcury cell.

    The cleanup was accomplished with a combination of isopropyl alcohol and acetone and elbow grease. The parts requiring cleaning were removed from the device to prevent contamination.

    The 1.35V reference was replaced with a circuit consisting of 2 AA batteries and a low voltage, low dropout regulator. This requires a minimum 2V input voltage, and with a quiescent current of 44uA, will probably last about 5 years on a set of batteries. The output measured 1.33V, which I thought was probably fine.

    The first test is to set the device onto voltage mode and centre zero. Then, with the zero switch enabled, the meter is zeroed on the most sensitive range.

    Unfortunately, when the zero is disabled, the output drifts very quickly on the most sensitive ranges.

    This is indicative of either flat batteries (no) or an input MOSFET problem :(
     
    Last edited: Jan 3, 2017
    (*steve*), Jan 3, 2017
    #2
    1. Advertisements

  3. (*steve*)

    davenn Moderator

    Joined:
    Sep 5, 2009
    Messages:
    12,100
    Likes Received:
    1,399
    Location:
    Sydney, Australia
    found the schematic .....
    so the only thing on the input board are the 2 FET's ?

    I assume you are not so worried about the originality of the internal looks as much as you are about calibration/spec issues
     
    davenn, Jan 3, 2017
    #3
  4. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    Joined:
    Jan 21, 2010
    Messages:
    23,010
    Likes Received:
    2,032
    Location:
    Mid way between Beijing and the Ronne Ice Shelf
    Along with the two FETs there are 2 devices which appear to be zener diodes (in TO-18 packages) and another pair of devices. It looks like either the schematic is "simplified" or was changed in a later version.

    I'll get some photos later today.

    Edit: oh yeah, whilst it would be cool to use exact replacements, getting it wiring again is more important.

    I have two of these units, so I'll put the batteries in the other (older and crappier) unit and see if it has a similar problem.

    Another issue is the type of solder used in this device. It seems to have a very high melting point (and you'll see why I know when I post some pictures)
     
    Last edited: Jan 3, 2017
    (*steve*), Jan 3, 2017
    #4
  5. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    Joined:
    Jan 21, 2010
    Messages:
    23,010
    Likes Received:
    2,032
    Location:
    Mid way between Beijing and the Ronne Ice Shelf
    He are some pictures (And I thought I'd let you see a hint of some wonderful warm evening weather as well)

    Firstly the Keithley 600B
    IMG_20170103_182244.jpg
    The manual can be found here and here. (Some parts are more readable in one vs the other)

    And with the side cover removed. The small board toward the lower back is the input board (which we shall see more of shortly)
    IMG_20170103_182342.jpg

    From the other side, there is lots of switching goodness
    IMG_20170103_182401.jpg

    Also on this side you can see the replacement for the mercury cell. This is on the board with the 2 AA cells and is connected to some pins soldered directly onto the old battery holder's terminals.
    IMG_20170103_182421.jpg
    The regulator is an AP7365, a low voltage adjustable low dropout regulator. The voltage divider consists of a 47k and a 68k resistor. At 600mA it has a typical dropout voltage of 0.37V, so at the very low current draw in this application, I estimate it will run until the battery voltage drops below 2V. I estimated the quiescent current would be about 100uA, but it turned out to be 44uA. Considering the typical quiescent current is 35uA and the current through the voltage divider is 12uA, I'm doing better than average! (my calculations were based on the max quiescent current of 80uA and an different divider with a slightly higher current). This should give me 55,000 hours of operation (over 6 years). No need for a power switch.

    When I soldered those two pins onto the battery holder terminals, it was *really* hard to get the existing solder to flow. Could it be silver solder?

    Here is a close-up of the input board.
    IMG_20170103_182443.jpg
    The two devices in thermal contact are the mosfets, the other 4 devices are C2N 3565 245 and are in a TO106 package -- on my other 600B these devices are in a TO18 package) and have only 2 leads connected. *IF* they are 2N3565's, it appears they may be using the BE junction as a zener diode as only 2 leads are connected and for the input gate terminal they are in inverse series as you would to protect the gate.


    Finally, another view of the FET board. It's probably easier to see some of the low current techniques used in its construction.
    IMG_20170103_182503.jpg
    Here is just the schematic. The actual FET board is more complex than is shown. My guess is that the version I have (labeled as a revision C on mine) is either improved over the original, or the schematic is simplified. The other components seem to be protection. I will try to draw out a schematic based on the information I have on the various devices.
     
    Last edited: Jan 3, 2017
    (*steve*), Jan 3, 2017
    #5
  6. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    Joined:
    Jan 21, 2010
    Messages:
    23,010
    Likes Received:
    2,032
    Location:
    Mid way between Beijing and the Ronne Ice Shelf
    Well, 2N3565's are still available. On ebay they go for anything up to $10 each. Apparently they are considered to hold some special form of magic for those who make guitar pedals.

    Do reverse biased base emitter junctions perform better than zener diodes? Less leakage perhaps?

    Without checking, it's hard to be certain that it's not the CE, or the BC junction being used. I guess a lot depends on the Vgs(max) of the mosfets.

    Just looking on eBay, there is a 600A available (which has valves). That would be really cool. Does anyone want to buy it for me :-D There are also 610C's available which are a later model.

    About 18 months ago someone asked about these input boards and gave the useful information that "The MOSFET's are labelled HD1G1030 and are Insulated Single-Gate MOSFET's". He was unable to find any information on these :-(

    I guess that these were a matched pair and that some substitute device with two mosfets in a single package should be fairly closely matched. I would imagine that low gate capacitance would be a factor to consider when choosing a replacement.

    Another option might be to look at the input design of the 610C, hoping that there is more information there... (Alas, no. The schematic is the same in the region in question, and although the transistors are listed, they are not described with a part number :-()

    For completeness, the 600A manual is here. 4 valves :)

    OK, it's really interesting that a group of these devices were tested as having an average GS breakdown voltage of 120V. That strikes me as pretty large compared with modern devices and points to both a thick oxide layer and a low gate capacitance. I've not actually tested any modern mosfets for breakdown voltage, so although I know they are typically rated at 20V or 30V, I'm not sure at what voltage they are likely to break down. I would assume it's well below 120V though.

    This has a low Vgs and a low Vds, but it may be the sort of thing I'm after.
     
    (*steve*), Jan 3, 2017
    #6
  7. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    Joined:
    Jan 21, 2010
    Messages:
    23,010
    Likes Received:
    2,032
    Location:
    Mid way between Beijing and the Ronne Ice Shelf
    I fitted the batteries into the other 600B and it has exactly the same drift issue.

    I guess there are a few possibilities:
    1. This is correct behaviour
    2. It is caused by the slight difference between the murcury cell reference voltage and my replacement
    3. Both units have the same fault in the input board.
    4. ???
    I'm pretty sure it's not normal, my reference voltage is only 0.02V low, and the input board is a known weak point.

    Whilst I'm going to check the manual again, my suspicions still rest on the unobtainium parts on the input board.

    If it is this board, then I have a few options:
    • Give up
    • Replace with lower spec parts (and lose functionality)
    • Replace the input (and have an uncalibrated le machine)
    • 2 of the above.
    I don't want to give up. I can't find suitable replacements, and reducing the functionality is a poor option. I want to have some chance of calibrating the instrument (even if it's not factory perfect).

    I've found a couple of devices with fA input currents, and my suspicion is that if I can use one of these to make a unity gain buffer, I can use lower spec input mosfets because their gate leakage and capacitance will be isolated from the actual signal source.

    I think this is the direction I'll go in. I may be able to "dead bug" one of these instrumentation amplifiers on to the existing board.

    Oh and on examination of the boards last night, the solder on the input board is clearly different to that used elsewhere. It is very shiny. The regular solder appears to be a very high temperature solder. Not sure what either solder is though...

    An LMC6041 or an INA116PA are on my list for review.

    The fact that I have +/- 18V supply rails probably pushes me to the latter chip. $USD20 each seems expensive, but freight will probably be higher!

    Edit: INA116PA are available locally, and cheaper than digikey! And free delivery! And in stock! (Will wonders never cease?)
     
    Last edited: Jan 5, 2017
    (*steve*), Jan 5, 2017
    #7
  8. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    Joined:
    Jan 21, 2010
    Messages:
    23,010
    Likes Received:
    2,032
    Location:
    Mid way between Beijing and the Ronne Ice Shelf
    AAAAGH! RTFM

    I have been reading the calibration instructions wrong.

    Of course the reading will wander all over the place when set for voltage measurements with the input open!

    The input leakage measurements are done in the amps mode.

    As near as I can measure, the leakage is a measly 5 x 10^-15 A, or 5 fA. And even that can be nulled out. Wow! At these levels, unscrewing the cover on the input connector pins the meter.

    And I have successfully measured resistors from 10k to 1G. On some ranges it seems to read a little low (5% at most) and measuring the 1G resistor is not done in an instant.

    I'm pretty impressed. Maybe I should order myself a 10G and a 100G resistor?

    OK, I'm impressed enough that I can ignore my embarrassment.
     
    (*steve*), Jan 5, 2017
    #8
  9. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    Joined:
    Jan 21, 2010
    Messages:
    23,010
    Likes Received:
    2,032
    Location:
    Mid way between Beijing and the Ronne Ice Shelf
    As another bit of fun on our space's open day yesterday, I set up the 600B to measure the photoelectric current from a yellow LED.

    Under the lighting on our electronics bench I measured it at about 5 nA.

    I wouldn't recommend using them as small solar panels :)
     
    (*steve*), Jan 8, 2017
    #9
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. reactgary
    Replies:
    0
    Views:
    1,061
    reactgary
    Jan 4, 2005
  2. perfb@yahoo.com
    Replies:
    0
    Views:
    637
    perfb@yahoo.com
    Nov 16, 2005
  3. Chris Carlen

    Keithley 2000 Multimeter?

    Chris Carlen, Dec 8, 2005, in forum: Electronic Design
    Replies:
    1
    Views:
    880
    John Larkin
    Dec 8, 2005
  4. blackhead

    Can a Triac BTA08-600B replace a BTB04-600SL?

    blackhead, Sep 13, 2007, in forum: Electronic Design
    Replies:
    5
    Views:
    3,000
    blackhead
    Sep 16, 2007
  5. Paul

    Keithley DMM - Canceling Input bias

    Paul, Sep 25, 2007, in forum: Electronic Design
    Replies:
    4
    Views:
    833
  6. Paul

    Keithley DMM - Canceling Input bias

    Paul, Sep 25, 2007, in forum: Electronic Equipment
    Replies:
    4
    Views:
    754
  7. mc

    MOSFETs for 3.3-V logic input?

    mc, Nov 14, 2007, in forum: Electronic Components
    Replies:
    0
    Views:
    657
  8. ebme.technician@googlemail.com

    Is replacing a BTA16-600BW with BTA16-600B going to cause problems?

    ebme.technician@googlemail.com, Dec 29, 2007, in forum: Electronic Repair
    Replies:
    2
    Views:
    988
    N Cook
    Dec 29, 2007
Loading...