Connect with us

Yamaha RX-V750 doesn't switch ON.

Discussion in 'Troubleshooting and Repair' started by Raghavendra K, Feb 23, 2015.

  1. Raghavendra K

    Raghavendra K

    16
    0
    Feb 23, 2015
    Hi Shabazxz, k3491 is equivalent to k3850 & they are interchangeable.
    After going through your input, I strongly feel the problem is in SubTrans section.
     
  2. Raghavendra K

    Raghavendra K

    16
    0
    Feb 23, 2015
    As you said, "I have mesured the voltages at the little transformer from the Subtrans and i have 86-90v" here the problem seems to be haunting. Check the rectifier (D408) which is in series with AC input. Meantime, did you check the capacitors C409, C405 properly?
    The voltages for 5M is just fine. Check all the resistors & Diodes which are connected to PDET & RES @ Subtrans section.
    Further, first check voltages at all the points seen on the image attached herewith. PDET seem to be originating from Q509 & Q501from function2 regulator section.
     

    Attached Files:

  3. Raghavendra K

    Raghavendra K

    16
    0
    Feb 23, 2015
    I am need of Function 2 PCB unit for Yamaha RX-V750 (identical to RX-V650). Is it possible for you to check for the availability at local stores near you?
     
  4. shabazxz

    shabazxz

    16
    0
    Apr 21, 2015
    Hello my friend. If i will find, i will tell you. I payd on 650 like this only 45$.
    I mesured C405 and has only 6nF, but i change and...nothing. I mesured the rest of the capacitor and all are good. Now for the D408 i dont find the S1NB60 but can i put one general rectifier 600V 1A? And i will change and the IC402, - TC4013bp, Q404 and i will mesure the diodes. 5M after the IC501 is 5.5 instead 5.7.Any ideea? THX
     
  5. Raghavendra K

    Raghavendra K

    16
    0
    Feb 23, 2015
    Hi Shabazxz, what is the voltage reading on PRY at SubTrans & Function2 PCB? If PRY is almost equal to what is required, we can check the transistor situated below the relay & the resistor connected to it.
     
  6. shabazxz

    shabazxz

    16
    0
    Apr 21, 2015
    PRY is 0. I have bypass-ed the relay and nothing. PDET and RES are 2.6V. Today i will change the D408
     
  7. shabazxz

    shabazxz

    16
    0
    Apr 21, 2015
    I have changed the D408 and still low voltage at the transformer.I have mesured the voltage at the Q404 and i have 5V,... but no 8.7 like in schematic.Now i will change the IC402 and Q404. Please tell me, what voltage do you have between the outside pins of Q404
     
  8. Raghavendra K

    Raghavendra K

    16
    0
    Feb 23, 2015
    Have you checked all the zener diodes? Once I had the same issue & I had to replace the zener diodes. Check the diodes correctly. Did you get S1NB60 for D408? I had to order them from eBay earlier. Since mine is 230v model, I am getting about 9V at Q404. Its turning out to be CATnMOUSE game. Please be sure to check the zener & resistors upon replacing the Q404.

    Bypassing the relay won't work, so don't try that method. You can try shorting PRY & +5M for 1 second and check whether the relay triggers.

    Unless PDET comes up, the receiver won't turn ON.
     
  9. Raghavendra K

    Raghavendra K

    16
    0
    Feb 23, 2015
    Please Check for voltages @ D511, D503, Q501 & R503 at regulator section of Function2 PCB.
     
  10. shabazxz

    shabazxz

    16
    0
    Apr 21, 2015
    Hello, its working. i have changed the IC TC4013BP and now its working. Good luck. If i will know something about the request, i will tell u.Thanks!!!!
     
  11. Raghavendra K

    Raghavendra K

    16
    0
    Feb 23, 2015
    Great and congrats. Its quiet unlikely for that chip to go bad...but it did.
    Great to hear the success and your commitment.
    I will wait to hear from you soon.
     
  12. Jozsef Csato

    Jozsef Csato

    1
    0
    Aug 3, 2015
    Hello Shabazxz, can I ask you how did you find out that the IC TC4013BP was faulty? Is there a way to measure it? I have the same amplifier and it's not powering on. Tried to replace the capacitors on the sub trans pcb but it's still not working.
    Any help would be appreciated.
    Thank you.
     
  13. shabazxz

    shabazxz

    16
    0
    Apr 21, 2015
    Hello. I changed all the capacitors and nothnig. On the PCB it,s a transformer. What voltage do you have? Look on the schematic and if the voltage it,s lower, change the IC. Other thing it is to watch the PURE DIRECT. If its blinking its the IC. But you have to look at night.
     
  14. Mousie

    Mousie

    1
    0
    Apr 30, 2017
    HI Folks, just joined as I have the same issue and just working through the sub-trans board and after a number of cap changes and verification etc. I have found my 2SK3850 (aka K3491) is dead so need a replacement. My issue after several hours of searching for equivalents almost all that I select are out of stock in Australia. Is the power dissipation of 20w for the Mosfet important in this circuit?

    The only two in stock are the following two that I am taking a guess on for voltage, current, speed and dissipation. Will these work or are there more common ones I should try with a good switching speed. Any help appreciated as I'm a home hobbyist but just the equivalent has got me on these Mosfets. Below are the two I am looking at as only ones I can find available and I suspect there are more in different brand names.
    IRFU1N60A and IPD60R2K0C6
     
  15. Raghavendra K

    Raghavendra K

    16
    0
    Feb 23, 2015
    I think I have couple of these 2SK3850 lying around. I am based out of India. Let me know if you are interested in. I can ship them to your address.
     
  16. kostas109

    kostas109

    1
    0
    Jan 20, 2019
    hello,can you help me?i have rxv650 amp and close after 1sec.in diag mode i take ps prt 000.any idea?
     
  17. Ylli

    Ylli

    226
    46
    Jun 19, 2018
    Kostas109, you might want to start your own thread.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-