Connect with us

Yamaha Aventage RX-A810 perfect but no audio

Discussion in 'Troubleshooting and Repair' started by edrlcnoc, Aug 1, 2019.

Scroll to continue with content
  1. edrlcnoc

    edrlcnoc

    2
    0
    Aug 1, 2019
    Hi, I am new to this forum and would appreciate some help in getting my Yamaha RX-A810 working properly again.

    I bought this unit about two years ago with no audio issue, but as it is in excellent condition all round, I would like to see if I can salvage it.

    The unit powers up, and all functions seem to work perfectly. The Tuner tunes to stations, the content on HDMI port is displayed properly on screen, the menus display on connected TV screen, and even the network connects via the wifi adaptor and I can control it with my phone via the app. I have tried to update firmware to the latest available version 1.80, and all goes well until it gives me an "Error! 0020" which, from reading on the web seems to be a DSP error, which sort of makes sense. I have tried normal RCA audio source on some AV inputs as well, but still no luck.

    The service manual (downloaded from elektrotanya.com) for this only has 6 pages (unlike most other Yamaha ones that have the full version, so that is the first challenge.

    Any assistance would be greatly appreciated.
     
  2. 73's de Edd

    73's de Edd

    2,840
    1,207
    Aug 21, 2015
    What happens when you place it in tuner mode and try to listen for audio thru HEADPHONES . . . . any audio then ?
     
  3. edrlcnoc

    edrlcnoc

    2
    0
    Aug 1, 2019
    When I plug in the headphones, I can hear the relay physically switching the audio signal over, but no sound from headphones from any source, including Tuner.

    I have just worked through the self diagnostic function on the receiver, and even in section A7 where the speakers can be tested with internally generated test tone, still no audio. In light of the "Error! 0020" that was indicated after trying to update firmware, I tested section dealing with the "Digital PCB Check", it fails only on section C1-7 DSP1: Bus NG. All other indicators are normal. (I used the RX-A820 manual in the absence of a service manual for RX-A810).

    Having a look at section S4 ROM VERSION/CHECKSUM
    DSP1 VERSION - S4-8 D1 - V -------- - No record here
    DSP1 CHECKSUM - S4-9 D1 - S -------- - No record here

    All seem to indicate that the DSP1 is the issue.
     
    Last edited: Aug 2, 2019
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-