Connect with us

Why won't field-oriented controlled PMSM motor spin in Simulink?

Discussion in 'Sensors and Actuators' started by Schenk123, Apr 25, 2020.

Scroll to continue with content
  1. Schenk123

    Schenk123

    1
    0
    Apr 25, 2020
    Good afternoon,

    I have developed a Field-Oriented Control for a PMSM motor in Simulink using Simscape Electrical but my motor is not spinning. I have tried applying various speed values but nothing happens. I am applying a step signal from 0 to 300 but the motor speed still doesn't move. My error signal, however, tracks my input as it should. I do not know what has happened. Could someone look at my simulation and tell me what is going on ? Screenshots of my signals are attached and simulink file can be downloaded from my OneDrive: FOC_SIMSCAPE.slx

    Screenshots: https://1drv.ms/u/s!AlkE9jIQZ7bthAQX82E6u1sLtgkf?e=hcL85R
     
    Last edited: Apr 25, 2020
  2. Nanren888

    Nanren888

    267
    54
    Nov 8, 2015
    I don't have simscape electrical, so can't try it. Nor have I doe anything much with rotating machinery, so unfamiliar with your blocks.
    I think I get the Clarke and Park stuff from the descriptions on Mathworks
    Sorry not familiar with/don't know what PWMTest does.
    I see a speed error.
    What's "theta"?
    What rotates? That is what turns speed into an increasing angle?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-