Connect with us

[Weird problem] Insignia 37" LCD

Discussion in 'Troubleshooting and Repair' started by Ryman230, Dec 24, 2015.

Scroll to continue with content
  1. Ryman230

    Ryman230

    2
    0
    Dec 24, 2015


    No clue what is going on for this to happen, and how to solve this. It all started after a few months of using my old xbox360 and now this is whats happened to it. The TV is about 9 years old and our second TV, which we used to project the xbox before, was 4 years old and smaller but similar in model, broke in the same manner.

    EDIT: If it doesn't fade out like that, it's just jittery and as though the picture is remaining the same, except like static-like display.

    Any information as to what this could be and how to solve it would be immensely helpful.
     
  2. Supercap2F

    Supercap2F

    550
    150
    Mar 22, 2014
    Hello Ryman230! Welcome to the Forums!

    Hmm, well first guess would probably be bad capacitors (one of the most common faults of all).

    Open it up and take a clear picture of any circuit board in sight. Post the photos here, and we'll see if there's anything obvious.
    Dan
     
  3. Ryman230

    Ryman230

    2
    0
    Dec 24, 2015
    Last edited: Dec 25, 2015
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-