Connect with us

Wanptek Power Supply KPS305D - Out not stable

Discussion in 'Power Electronics' started by abuhafss, Apr 15, 2020.

Scroll to continue with content
  1. abuhafss

    abuhafss

    348
    11
    Aug 3, 2010
    Hi

    My bench power supply has started giving unstable output. The voltage fluctuates continuously even when the POT is idle. The PCB inside shows no damaged or burnt component. No domed capacitors.

    Any idea, what's wrong with it?
    20200415_173632_001.jpg
    20200415_173433.jpg
     
  2. davenn

    davenn Moderator

    13,555
    1,853
    Sep 5, 2009
    is this with or without load ?
     
  3. abuhafss

    abuhafss

    348
    11
    Aug 3, 2010
    Without any load.
     
  4. abuhafss

    abuhafss

    348
    11
    Aug 3, 2010
    One more point, when the voltage POT is turned slowly to maximum, before reaching the limit a slight mechanical click heard and the voltage slowly goes down to 0. Then, if the POT is turned slightly towards the minimum side the click sound is heard again and the voltage changes abruptly.
     
  5. Martaine2005

    Martaine2005

    2,659
    718
    May 12, 2015
    This sounds like dirty pot contacts.
    But, is the click you hear a relay?. Some of these bench supplies have relays for different voltages.
    Could still be as easy as cleaning the pot or pots with contact cleaner.
    I would do this first to rule it/them out.

    Martin
     
  6. abuhafss

    abuhafss

    348
    11
    Aug 3, 2010
    Thanks for the tip, it worked.
     
    Martaine2005 likes this.
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
Loading...
Electronics Point Logo
Continue to site
Quote of the day

-