Connect with us

Vizio E421VA no pic or sound

Discussion in 'Troubleshooting and Repair' started by HipMusic man, Sep 21, 2013.

Scroll to continue with content
  1. HipMusic man

    HipMusic man

    6
    0
    Jul 8, 2013
    the tv was given to me for free to repair and either keep or sell. so im trying to repair it. i have replaced the power supply with what i believe to be a fully working power supply but there was no change. when i test the power supply the voltages are correct. however, when i test the voltage going out to the tubes (backlight) there is no reading. it says high voltage all around that area so i suspect there should be something on the meter. any ideas?
     
  2. davenn

    davenn Moderator

    13,560
    1,856
    Sep 5, 2009
    The tube's backlight ?

    is it a plasma screen ? a LCD panel ??

    LCD panel backlights often use fluro tubes with ~ 3000V supplies
    they will "bite" or kill your meter if you measure incorrectly

    have you google searched for a service manual or schematic ?

    Dave
     
  3. HipMusic man

    HipMusic man

    6
    0
    Jul 8, 2013
    lcd

    thats a lot of volts.

    not yet
     
  4. HipMusic man

    HipMusic man

    6
    0
    Jul 8, 2013
    i cannot find a schematic for it
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-