Connect with us

Variable duty cycle and frequency with a 555

Discussion in 'Electronic Design' started by captoro, Apr 25, 2013.

Scroll to continue with content
  1. captoro

    captoro Guest


    How fast rise time ?? .. Fast , I am experimenting now, the fastest as possible !.
    I have been working on a circuit with a PIc chip like I said earlier works good, well kinda.
    OH. before I forget I did install some 5 and 10 turn POT, some old shop near my house had a drawer full, I took 6 for 20$ .
    The circuit seems to work at 12v input through the coil, But if I put 24v (I have not tried 36v yet as seen on the schematic) the coil get pulsed on and off in a random fashion !!
    I'LL hook up the scope on the PIC see what happens
    And yes all the grounds are connected together and then connected to a metal rod in a proper grounding fashion.
    K
     
  2. captoro

    captoro Guest

    here is the link:
    http://www3.sympatico.ca/captoro/
     
  3. Jamie

    Jamie Guest

    Trying to figure out what you're attempting to make has become
    challenging. In the above link it states you have 6 MFETS in series?
    I can only imagine you mean they are in series on a heat sink but
    electrically together in parallel?

    Next, you don't state if the 10uh coil is a high Q type and maybe
    a rather large one?

    You do realize that with fast edges you'll end up with lots of voltage
    at the drain? Of course you could load the DRAIN down with caps and
    make an induction heater coil using the ringing to generate the 50khz
    average that is generally used.

    Just a thought.

    Jamie
     
  4. captoro

    captoro Guest

    Hi, there are 8 Mosfet in parallel in tow rows. they are rated 400v .
    the problem I am getting is when I supply current to the coil, (which is probably not 10uH because I used the default one in Orcad, I'll need to calculate if you want. It has 300 feet wire wrapped on a 2 inch diameter PVC and3 inch long) . the problem is when I put on the 36v actually 24 v, the output pin from the picchip stops randomly for oscillating ....
    I mean 1 second on 0.5 second off etc...

    K
     
  5. mike

    mike Guest

    A quick sanity check registers in the insane region.

    If you put 36V into 10uH, the back of my envelope says the current ramp
    is 3.6 MILLION AMPS/SECOND.
    Round numbers...1 kHz. 99% on time is still 3.6 thousand amps.
    And that's only the first pulse.
    I think you're gonna need bigger wire.

    Unless you're located at the power substation, it's not surprising that
    something is shutting down.

    The thing seems fraught with issues.

    What are you trying to accomplish?
     
  6. captoro

    captoro Guest

    I modified the circuit value, because i said earlier that the coil value was not good, Now after measuring it I posted up the corrected circuit.
    what I am trying to accomplish??
    I am trying to replicate a motor winding
    But pulsed instead of using steady DC.
    But my pic randomly stops working, I would understand if the fuse blows, heating wire ... but why would it stop, I am thinking it comes from the ground, sharing the same ground as the coil. ?!?

    K
    K
     
  7. mike

    mike Guest

    might be resetting the pic. Put a led+resistor on one of the outputs
    and flash it during
    initialization of the pic.
    That will tell you if it's resetting.
    I just looked at the pictures.
    I don't think you have a prayer of making that work.
    You've got wires running all over the place and huge magnetic fields
    being generated.
    Get the PIC and the pots and display in a shielded box away from the
    FETs with lots of power supply decoupling.

    The shielding may not help much with magnetic coupling, but making
    the wiring shorter will help.
    You may be able to get the FET ground currents contained by careful
    management of what is wired to what and parallel conductors for + and -
    to minimize the magnetic field. If not, you can try transformer or IR
    coupling from the pic to the driver.

    You can't just turn off the FETs with current in the inductor.
    The energy has to go somewhere. It's best to control where it goes.
    Google "Miller Capacitance" and see if you have enough drive
    to charge the EFFECTIVE input capacitance. That also explains
    why the FETS are so slow turn off...and will get hot.

    Are we having fun yet?
     
  8. captoro

    captoro Guest

    I thought of using optos too, i just didnt have here that are fast enough.
    I think that might be the problem, The wires are the shortest I can put them , Except for a load parallel to the coil with two diodes.
    k
     
  9. mike

    mike Guest

    Except for a load parallel to the coil with two diodes.
    That's nonsense.
    Get the PIC out of the middle of all that high-current high-voltage stuff.
    You've got pot wires curling around the fets.
    No sight of any power supply bypassing. OR decoupling.
    You can't just "wish" that it works. You gotta design it
    so it works and rearrange the wiring so it can work.
    There's some art to this kind of circuit. The reason your pic
    might be resetting is not on the schematic you posted.
    Redraw the schematic with the grounds connected exactly the way
    they are in the wiring. Insert inductance and resistance in every
    ground lead. Then add some mutual coupling between those inductors.
    It's not magic, but it is tedious.

    Get rational about the voltages/currents/risetimes you need.
    Fast as possible, is not a spec. Any mention of 10ps risetime
    for this circuit is ludicrous. Put numbers on what you need
    and design for that.
     
  10. captoro

    captoro Guest

    Should I make a board for the PIc & mosfet driver and a separate board the mosfet and coil??

    k
     
  11. mike

    mike Guest

    You could make an argument for either. The idea is to get the PIC out of
    the middle of all that high current stuff and limit the "antennas" for
    all the interconnect rat's nest.
    The PIC/knobs/display is a useful piece of test equipment. In that
    respect, it makes
    some sense to package that together.

    There's still too much undisclosed to be able to offer much help.
    On the path you're on, you're gonna learn how inductors behave.
    And you already know that.
    And when you finally get it working, you're likely to learn how
    to blow up fets 8 at a time...and magnetize everything within reach.

    You still seem to be working on the "best as possible" theory.
    Figger out what you need before you build it. Numbers are your friend.

    If you're gonna drive a motor, hook up the motor and deal with all
    the parasitic effects.
     
  12. captoro

    captoro Guest

    Jim,
    I am trying to replicate an experience i saw on youtube:

    I am using a different oscillator, the rest is the same
    K
     
  13. captoro

    captoro Guest


    I posted the schematic on my web site. But he uses a 555 timer, and at the output a CFL is to be placed.

    K
     
  14. mike

    mike Guest

    Nope, the rest ain't the same.
    He separates the functions and manages the ground currents.
    The devil is in the details and often not shown on the schematic.

    WOW! A video showing that he can flash a light.
    Makes no claims.
    Draws no conclusions.
    I want the 7 minutes of my life back.
     
  15. captoro

    captoro Guest

    Thanks Jim I will try your circuit.
    here is the original post:

    You cannot see the CFL, but there is another video which he has 5 CFL fully turned on. Hes got wires going all over the thing. Plus in my circuit pictures, all the black wires are redundant ground on the board,
    K
     
  16. josephkk

    josephkk Guest

    What a horror. I am surprised that the CFL didn't emit smoke. I can only
    find a lightning strike a worse torture for the internal driver circuit.
    It is definitely worse that IEEE Class C impulse rating.

    Use a full transformer with L-R series load, instead of a simple inductor
    to model a motor. You will find a real motor jumpy and twitchy at the low
    frequency range of your system.

    ?-)
     
  17. captoro

    captoro Guest

    You think that is crazy, with this simple oscillator , he is able to light 5 CFL on this video:

    I can hardly dim one with my circuit !!
    Apparently some people has been able to replicate it. so that what I am trying to do

    K
     
  18. captoro

    captoro Guest

    I added an opto coupler to the circuit to isolate the ground from the coil.
    Its working 100%
    BTW I thought about the EM wave some where mentioning earlier, I am only oscillating at 5Hz, so I dont think that is an issue here
    Thank for all the time you gave me
    K
     
  19. Bill Sloman

    Bill Sloman Guest

    John Larkin's rather than John Fields'.
     
  20. josephkk

    josephkk Guest

    Just in case you are still reading, the EMI issues come mostly from edge
    speeds rather than fundamental frequency.

    ?-)
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-