Connect with us

urgent: chopper stabilized amplifier's amplifier stage does not work

Discussion in 'Electronic Design' started by tiger66, Mar 10, 2007.

Scroll to continue with content
  1. tiger66

    tiger66 Guest

    Hi
    I searched the component name LTC1043 on LTspice, but I can't seem to
    find it. Is it an extra component I need to download?

    If you have one, can you please email me a copy?


    I simulate my chopper stabilized circuit on multisim because I can't
    find a way to generate spectral analysis of a signal on LTspice. Can
    LTspice do spectral analysis?

    A major problem I have right now is I can't get the opamp stage of my
    chopper stabilized amplifier to work. I try to simulate Fig4a in the
    article "A CMOS Chopper Amplifier" by Christian C. ENZ.

    I can get the input modulator to work but after I attach the opamp, I
    get a "timestep too small" error message every time I simulate. I
    tried changing the end time to a big number, but it doesn't fix the
    problem either :(

    Can someone please give me some assistant.

    I can email you the article and my multisim file if that makes it
    easier to understand my problem

    Thanks
     
  2. Eeyore

    Eeyore Guest

    Yes. EWB, Multisim's predecessor does that a lot too. Can you simplify the
    circuit at all ?

    Graham
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-