Connect with us

TV Daewoo CP420

Discussion in 'Electronic Repair' started by Francis, May 29, 2004.

Scroll to continue with content
  1. Francis

    Francis Guest

    Hello,

    I am trying to repair a combo TV/VCR Daewoo chassis CP-420. The stdby
    LED is ON but nothing starts. I have checked followings :
    - the relay in the primary of power supply switch off after one/two
    second. It is driven by signal VCR ON. Means some defect in VCR ?
    - If I force the VCR ON signal then it looks like the main supply is
    ok, all voltages on secondary are according to specs. However still
    nothing happens. No pulses on HD signal which drives the line
    transistor. Also the MON ON signal keeps low, this one drives the
    relay switching the 123V to HVT.
    Any suggestion is welcome, thanks in advance.
    Please answer on the group.
    Francis
     
  2. Jerry G.

    Jerry G. Guest

    Is the scan generator for the horizontal output and high voltage working
    properly, or at least getting its kick-start?

    Did you do an ESR test on all the caps in the power supply and scan
    sections?

    Is the HOT or any of the power devices shorted, or defective?

    Other than that, you must get the service manual, and properly follow it up.

    --

    Jerry G.
    =====


    Hello,

    I am trying to repair a combo TV/VCR Daewoo chassis CP-420. The stdby
    LED is ON but nothing starts. I have checked followings :
    - the relay in the primary of power supply switch off after one/two
    second. It is driven by signal VCR ON. Means some defect in VCR ?
    - If I force the VCR ON signal then it looks like the main supply is
    ok, all voltages on secondary are according to specs. However still
    nothing happens. No pulses on HD signal which drives the line
    transistor. Also the MON ON signal keeps low, this one drives the
    relay switching the 123V to HVT.
    Any suggestion is welcome, thanks in advance.
    Please answer on the group.
    Francis
     
  3. Francis

    Francis Guest

    Hi Jerry,

    Thanks for your inputs.
    Although experienced in electronics, I am not a professionnal for TV repair.
    I don't know where to get the service manual.
    I will try to get an ESR meter and follow your advices, concerning caps.
    HOT is good. The vertical IC is powered by the HVT, so not in question up to
    now. All regulator outputs are ok.
    For the scan generator TDA8374A, the sine wave at the xtal oscillator is ok.
    Maybe you can give more advice how to check it (which signal is the kick
    start ?..).
    Thanks again and best regards.

    Francis
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-