Connect with us

Trying to power on an unidentified Voltcraft oscilloscope.

Discussion in 'Troubleshooting and Repair' started by dtrUdev, Jun 18, 2011.

  1. dtrUdev

    dtrUdev

    3
    0
    Jun 18, 2011
    Hello,
    I am trying to switch on an old scope I last saw working around 5-10 years ago.
    It is of the brand Voltcraft but it has no model number, just a serial number.
    I have no user manual or schematics.
    I attached pictures of the front and back panels as well as the marking on the pcb, in case someone owns one of those (I could not find a similar one on google images).

    The symptoms are that there is nothing on (the led & cathodic tube) and no humming from the transformer.

    I have noticed that the power plug connects to the back of a pot through two fuses (one per power line). The pot has two knobs, the external one controls the front plate, the internal one controls the middle plate and there is a white plastic back section to which the two power lines connect to. There are two other cables on that back section which connect to the transformer (I attached a picture in case someone knows this type of pot and can tell me what this back section is supposed to do).

    Those four pads of the back plate seem to be isolated from each other except the two connected to the transformer on which I measure what I think is the resistance of the transformer coil:146 ohms.
    When the oscillo is plugged in I can measure 220 volts on the power lines but no voltage on the other two.
    I tried turning, pressing and twisting the knobs and could not measure any conductance (when off) or voltage (when plugged in).

    I suspect the role of that white part on the pot is a switch. but as I measure 146 ohms on the transformer and the back plate states 25 VA, I am reluctant to connect 220V directly to the transformer.

    What do you think ? What would you do ?

    Thanks for your help
     

    Attached Files:

  2. Resqueline

    Resqueline

    2,848
    1
    Jul 31, 2009
    The white section on the back of the pot is a DPST mains switch. Does it click properly?
    If not then some plastic pin inside might be broken, or some grease inside might have gone stiff
    If the possibly hardened grease is not stopping movement it could just be insulating the contacts.
    Try to get some contact spray inside anyway.
    Two wires should come from the mains fuses with 220V on them, and the other two should go to the transformer.
    The picture of the pcb means nothing to me without a picture of the other side.
     
  3. dtrUdev

    dtrUdev

    3
    0
    Jun 18, 2011
    Thanks for your reply.
    The switch does not click so I cut the wires and closed the circuit.
    This worked :) I get a signal on the CRT.
    However there is a curve that gets super imposed on the actual readings of the probe.
    That curve can also be seen when the probe is connected to ground.
    I'll video it tonight and post to see if I can get hints on where to proceed from here.

    Thanks again.
     
  4. Resqueline

    Resqueline

    2,848
    1
    Jul 31, 2009
    Old scopes sometimes develop oxidised contacts in their switches when they've been sitting idle for years. This can give rise to many strange symptoms.
    Use contact spray in all switches and operate all of them vigorously.
     
  5. Antia2000

    Antia2000

    1
    0
    Aug 6, 2011
    Scematic diagram for Voltcraft oscilloscope

    Did you found a schematic diagram for your scope?
    If you still have not, please let me know, so I can send it.

    Antigona
     
  6. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,178
    2,690
    Jan 21, 2010
    Antia2000, if you can, please consider uploading your manual to ebaman.com.

    This is a great place to submit manuals and you may well be of assistance to more people.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-