Connect with us

Trouble Shooting this Circuit Board

Discussion in 'General Electronics Discussion' started by kevinkhan, Sep 26, 2013.

Scroll to continue with content
  1. kevinkhan

    kevinkhan

    4
    0
    Sep 26, 2013
    This circuit board is from a Show Tec Multidim Mk111
    http://www.thomann.de/ie/showtec_multidim_mkii_dmx.htm

    Its used to control disco lights going on and off.

    When i power on the unit all the lights should be off because there is no dmx signal going to each of the 4 channels.For some strange reason the second channel (the one highlighted in the image) stays turned on.

    I think the black devices attached to the aluminum heat sink are PNP N devices. This is what is written on them BTA16 600B Mar 111B0

    Is there any way of trouble shouting this board and can anyone tell me what could be a possible cause.
     

    Attached Files:

    Last edited: Sep 26, 2013
  2. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,497
    2,839
    Jan 21, 2010
    I think they are triacs (16A triacs)

    Are lights connected to the second channel turned on even when there is no power to the ShowTec? (This may not be a diagnostig question if power to the showtec also supplies the loads.

    I would suspect a shorted triac as a first guess.

    What load were you using on this channel? Was it an incandescent load near the maximum rated load?

    Does the affected triac look differnt to he others? any chips or cracks? And smoky white residue?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-