Connect with us

TL074 CN test

Discussion in 'Troubleshooting and Repair' started by Coconuttopdrop, Sep 7, 2012.

  1. Coconuttopdrop

    Coconuttopdrop

    6
    0
    Sep 7, 2012
    Hi.

    I'm repairing a AMEK mixing board but i dont have an extensor to power the channel's that i'm fixing.
    What i'm doing is comparing some readings on a good channel with the bad channel.

    The EQ section of the board as 4 TL074CN IC's, and some are busted, but i dont have a way to see wich are ok and wich are busted because i cant power the circuit.

    So i need to do some kind of circuit to test the IC's.
    The TL074 brochure has a audio amp circuit (fig.25) wich i can try to replicate, but i have some questions.

    Using a DC power supply, should i feed 12V to CC+ and hook up the ground to CC- and feed 6V to ground?

    Thnks
     
  2. Harald Kapp

    Harald Kapp Moderator Moderator

    9,137
    1,846
    Nov 17, 2011
    That is not the way to connect the supply to the OpAmp.
    For Vcc+ = 12 V use Vcc-=-12 V and GND=0V. You need a dual supply or 2 supplies. Or you build a virtual ground. Both techniques are discussed here.

    To give the issue another spin: Why build a (comparatively) complex test setup which still will not tell you whether the OpAmp will work correctly in the original circuit? The TL074 is rather inexpensive. I'd just replace all the OpAmps by new ones.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-