Connect with us

Tektronix 2215a

Discussion in 'Troubleshooting and Repair' started by Plasmah77, Jun 6, 2010.

  1. Plasmah77

    Plasmah77

    9
    0
    Jun 6, 2010
    Hi all

    I need help.

    I recently acquired a used Tektronix 2215A from Ebay. And the unit seems to work as far as I can tell. I used the probe adjust which is 1 Khz/500 mV. And it did read and display as such.

    The problem with the unit is the Trigger. No matter what I do I cannot seem to freeze or stabilize anything on the screen. The wave form moves left or right but never stays put. The only thing I can get it to do is SLOW down but that's about all.

    Please help

    Thanks

    Jim
     
  2. davenn

    davenn Moderator

    13,323
    1,769
    Sep 5, 2009
    Hey Jim,
    cant help directly tis a good looking scope I own a very much older 465B 100MHz unit.
    BUT I do belong to a yahoo group devoted to tektronix collecting and repair. Im sure some one there would help you out :) it has a huge membership
    http://groups.yahoo.com/group/TekScopes/ see how you go

    Dave
     
  3. Plasmah77

    Plasmah77

    9
    0
    Jun 6, 2010
    Wow

    Thanks Dave

    Was looking for a place like that ;)
    I will do some looking there.

    Have a good one.

    Jim
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-