Connect with us

TEK 475 Scope-stopped

Discussion in 'Electronic Repair' started by Dave_s, Mar 28, 2005.

Scroll to continue with content
  1. Dave_s

    Dave_s Guest

    Hi,

    My favorite old TEK 475 Scope has suddenly stopped working.
    Symptoms are:
    No trace, screen is blank, intensity and focus control do nothing.
    Beam Finder shows a dim small circle middle of screen.
    When power is turned off, circle like BEAM FINDER same size is visble
    and bright
    for a breif moment.
    Panel LEDS are lighted and do respond to switches being changed.
    Screen graticule cannot be seen.

    Any suggestions are welcome. I currently do not have an adequate
    service manual,
    just module layout and parts list. I am looking but cannot find the
    TEKTRONIX
    scope forum.
    Thanks for any help. Dave_s
     
  2. http://groups.yahoo.com/group/TekScopes/

    Sounds like power supply issues to me. First and foremost, get a
    proper service manual. Second, use its info to check every electrolytic
    in the power supply section.

    Happy hunting.



    --
    Dr. Anton T. Squeegee, Director, Dutch Surrealist Plumbing Institute.
    (Known to some as Bruce Lane, ARS KC7GR,
    kyrrin (a/t) bluefeathertech[d=o=t]calm -- www.bluefeathertech.com
    "If Salvador Dali had owned a computer, would it have been equipped
    with surreal ports?"
     
  3. tekman

    tekman Guest

    Hi Dave,

    contact me via PM at and I send you a scan of the 475
    serv. manual free.

    hth,
    Andreas
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-