Connect with us

Technics SU C2000

Discussion in 'Electronic Repair' started by N_Cook, Jul 8, 2008.

Scroll to continue with content
  1. N_Cook

    N_Cook Guest

    Expensive control amp/ preamp
    Scratchy motorised/sevo volume control. Anyone been here before, any pifalls
    opening up etc ?
     
  2. N_Cook

    N_Cook Guest

    Not made to be taken apart. Long rivets and star circlip. Unusually ,
    constant but fairly low level of crackle over 80 percent of one track.
    Presumably loss of
    plating on conductor track so varying different metal Seebeck voltage or
    chemical
    corrosion perhaps .
     
  3. N_Cook

    N_Cook Guest

    With this sort of problem cannot see resistance amisss by checking with a
    DVM.
    Worn track but only worn down, not through. 3 sets of wipers per pot and 3
    circular paths, conductor, 100 K resistor and low resistance inner ring of
    about 20 ohms around.
    Probably problem due to corrossion over most of the wiper fingers and this
    central contact ring.
    The pitfall is a not noticed/seen, presumably cartouche shape widget, that
    locates that shape hole in the pot paxolin to the smaller same shape of axis
    shaft. I must have removed both together thinking they were one part and
    lost the widget before placing in tray or sticking to something else and
    losing. Had to fashion one from a couple of transistor insulated washers and
    epoxy.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-