Connect with us

Technics SL1210 speed problem

Discussion in 'Electronic Repair' started by Ron(UK), May 15, 2007.

Scroll to continue with content
  1. Ron(UK)

    Ron(UK) Guest

    I don't see many of these.
    When the pitch slider is moved from the centre detent, the green led
    goes dim but not completely out, it flickers slightly and the speed
    varies in time with the flicker. The pot seems ok.

    Has anyone been here before? is it just the slider pot, or some problem
    with the quartz pitch lock?

    Ron(UK)
     
  2. N Cook

    N Cook Guest

    there are 1200 and 1210 repair briefs on
    http://www.divdev.fsnet.co.uk/repair3.htm
    file of mine
     
  3. Arfa Daily

    Arfa Daily Guest

    Usually just the pot. The servo circuitry is generally very reliable on
    these. There are aditional contacts for the indication. About 50% of the
    time, the pots will strip and clean. Otherwise it's a case of replace it.
    These are very popular decks with the DJ-ing fraternity, and the parts are
    readily available for very reasonable prices, direct from Panasonic.

    Arfa
     
  4. Ron(UK)

    Ron(UK) Guest

    Many thanks for that Arfa, much appreciated.

    Ron(UK)
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-