Connect with us

Teach me all about picaxe

Discussion in 'General Electronics Discussion' started by Jakerader, Oct 14, 2013.

Scroll to continue with content
  1. Jakerader

    Jakerader

    14
    0
    Oct 14, 2013
    Someone teach me about picaxe I'm facing problems and they need to be solved ASAP
     
  2. KMoffett

    KMoffett

    723
    75
    Jan 21, 2009
    Why don't you go to the PICAXE forums. http://www.picaxeforum.co.uk/forum.php There are very knowledgeable, helpful, and friendly people there.

    Tell them very clearly what you need to do. It will save you and them time.

    Ken
     
    Last edited: Oct 14, 2013
  3. Jakerader

    Jakerader

    14
    0
    Oct 14, 2013
    it says i dont have the privileges to post a thread or comment on the forum section, and i dont want to buy a membership, do you have any idea about microcontrollers
     
  4. KMoffett

    KMoffett

    723
    75
    Jan 21, 2009
    You don't have to buy a membership. Just register with the forum., like here. I have used PICAXEs. What are you trying to do?

    Ken
     
  5. Jakerader

    Jakerader

    14
    0
    Oct 14, 2013
    cheers

    i have an AXE230 microcontroller, ok, and i think i have soldered it all properly and i have wired up the battery pack and serial lead correctly but when i click on check firmware or program after typing my code it says something along the lines of error finding 08M2 on com 3, the same thing happens on com 1 aswell, does that make any sense?
     
  6. KMoffett

    KMoffett

    723
    75
    Jan 21, 2009
    Are you using the USB-Serial download cable?

    Ken
     
  7. KMoffett

    KMoffett

    723
    75
    Jan 21, 2009
    Are you using the USB-Serial download cable? What operating system XP? 7?

    Ken
     
  8. Jakerader

    Jakerader

    14
    0
    Oct 14, 2013
  9. KMoffett

    KMoffett

    723
    75
    Jan 21, 2009
    Basically the computer program is trying to get the PICAXE to respond. This is a common problem with people first using the PICAXE. With their cable it should be straight forward.
    Check >Control panel>system>device manager>com ports to see which com ports are available.

    This where the PICAXE form people are really helpful.

    Ken
     
  10. Jakerader

    Jakerader

    14
    0
    Oct 14, 2013
    com 1 and com 3 are available, now what?
     
  11. Jakerader

    Jakerader

    14
    0
    Oct 14, 2013
    If my cable works with other things, the led still comes on the pcb board, my computer works fine, my leads are fine, does it mean that i have soldered my download socket to the PCB microcontroller board incorrectly?
     
  12. KMoffett

    KMoffett

    723
    75
    Jan 21, 2009
    This is where you need to go back to the PICAXE forum. Go to the "Active PICAXE Forum" and do a search on "AXE026". This will give you threads where people have download problems, and hopefully, solutions that you can try.

    I'm no expert!

    Ken
     
  13. Jakerader

    Jakerader

    14
    0
    Oct 14, 2013
    haha, sorry you sounded like one, haha, cheers for all your help hopefully i will find something, but i still cant post a thread or comment/ message on the picaxe forums even though i have registered
     
  14. KMoffett

    KMoffett

    723
    75
    Jan 21, 2009
    As I remember it takes a day or so for the moderator to authorize you registration. It keeps the spammers out. I think you can still do a search.

    What do you mean "my cable works with other things"?

    Ken
     
  15. Jakerader

    Jakerader

    14
    0
    Oct 14, 2013
    I mean my computer knows it's there and when I connected it to my Sony phone it said on hardware Sony Ericsson memory card, or something like that.
     
  16. KMoffett

    KMoffett

    723
    75
    Jan 21, 2009
    So to talks to your computer OK, but not to your cellphone?

    Ken
     
  17. Jakerader

    Jakerader

    14
    0
    Oct 14, 2013
    hi its me again, i've fixed the last problem, but now i have a walking problem, i've built it and i've downloaded a code to it but instead of walking it marches on the spot, any ideas, here is the code:

    symbol lfoot = 1 ' set the pin number for servo
    symbol rfoot = 4 ' set the pin number for servo
    symbol balance =2 ' set the pin number for servo
    symbol round = b6 ' variable used to loop one left + right footstep
    Symbol LFoo = b0 LFoo = 120 ' Set and initiate feet twister variable
    symbol balanservo = b3 balanservo = 166 ' Set and initiate balance variable (10 more than optimal balance / middle for the balance servo)

    servo lfoot, LFoo ' initiate servo
    servo rfoot, LFoo ' initiate servo
    servo balance, balanservo ' initiate servo

    symbol speed = 1' set to higher for slower walking
    wait 5 ' wait for the robot to be placed on ground before moving


    main:
    for round = 1 to 120 ' main variable to dictate all action flow
    select case round
    case 1 to 60
    inc lfoo

    if round < 15 then
    balanservo = balanservo +1
    endif
    if round > 40 and round < 50 then
    balanservo = balanservo -2
    endif
    if round> 49 then
    balanservo = balanservo -1
    endif

    case 61 to 120
    dec lfoo

    if round < 75 then
    balanservo = balanservo -1
    endif
    if round > 100 and round < 110 then
    balanservo = balanservo +2
    endif
    if round > 109 then
    balanservo = balanservo +1
    endif

    end select

    ' Set servos:
    servopos balance, balanservo
    servopos lfoot, lfoo
    servopos rfoot, lfoo
    pause speed
    next round
    goto main



    can you see any reason why it would not walk forward?
     
  18. KMoffett

    KMoffett

    723
    75
    Jan 21, 2009
    Jakerader,

    I have no idea what you're talking about. Don't assume that I somehow telepathically follow what you have done, are doing, or want to do. Did you make some kind of robot?

    Ken
     
  19. Jakerader

    Jakerader

    14
    0
    Oct 14, 2013
    haha

    yes i have made some form of robot, thats the robot so far, i just posted for anyone to respond cheers anyway
     

    Attached Files:

  20. Jakerader

    Jakerader

    14
    0
    Oct 14, 2013
    do u think it will help if i put the neck and battery pack on it to give wieght at the front, do u reckon that will make it go forward?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-