Connect with us

TEAC tv high pitch squeal and not powering on.

Discussion in 'Electronic Repair' started by User, Nov 12, 2003.

Scroll to continue with content
  1. User

    User Guest

    G'day!

    I thought I'd ask for a hand in here, calling on some previous experience to
    see if I can get to my problem a bit faster......

    I have a Teac Tv which I inherited from a friend, as it was faulty and I
    like to dable in electronics when i can.

    When the set is powered up, it makes a high pitch squeal which goes audibly
    down in steps when you turn the set off......

    At first, i thought it would be the EHT, so I replaced it (as the set was
    free, i didnt worry too much about the cost factor), but it wasnt!

    The set still makes the squeal when turned on, and still not firing up
    ......no pic or anything.

    Anyone have any ideas before I start hunting????

    Horiz. output?

    CHEERS!

    IB.
     
  2. David

    David Guest

    Look for a hard short on one of the secondaries of the SMPS.
    David
     
  3. Zotin Khuma

    Zotin Khuma Guest

    In my experience, 9 times out of 10, yes. The horiz output transistor
    is probably a dead short.

    -Zotin
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-