Connect with us

Switch mode power supply

Discussion in 'Electronic Repair' started by Joe, Feb 23, 2004.

Scroll to continue with content
  1. Joe

    Joe Guest

    Hi,

    I have a 9V, 0.75A switch mode power supply which has a strange problem. It
    does not work (i.e. no voltage output) unless I _slowly_ slide in the IEC
    mains lead (so that it sounds like there is some arcing) the first time I
    use it for a while. If I just plug in the mains lead quickly or turn on the
    socket at the wall it does not work. After it has worked once, and the unit
    is slightly warmer perhaps, it operates fine. I can turn it off and on again
    at the wall socket with no problems.

    Any ideas?
    Joe.
     
  2. Usually, problems that disappear when something warms up are either
    bad connections or dried up electrolytic capacitors - the latter being
    more likely in this case.

    --- sam | Sci.Electronics.Repair FAQ Home Page: http://www.repairfaq.org/
    Repair | Main Table of Contents: http://www.repairfaq.org/REPAIR/
    +Lasers | Sam's Laser FAQ: http://www.repairfaq.org/sam/lasersam.htm
    | Mirror Site Info: http://www.repairfaq.org/REPAIR/F_mirror.html

    Important: The email address in this message header may no longer work. To
    contact me, please use the feedback form on the S.E.R FAQ Web sites.
     
  3. Sofie

    Sofie Guest

    Joe:
    Very likely the problem you described is caused by faulty or high ESR
    electrolytics...... don't continue nursing this problem along..... soon,
    you may not be able to get it to work at all and additional components
    including the switching transistor or chip may fail. If you do not have an
    ESR meter, just replace ALL of the electrolytics.
     
  4. Joe

    Joe Guest

    Thank you both for the advice.
    Joe
     
  5. w_tom

    w_tom Guest

    Heat being a significant factor, then you should also know
    about the inrush current limiter. When it gets warmer, then
    it conducts electricity. Cold - it may limit power so small
    that power supply cannot start. However you don't know
    anything about that supply until you take some multimeter
    readings. This assumes (of course) that you intend to repair
    this supply.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-