Connect with us

Swan mark 2 vintage HF RF amp.

Discussion in 'Radio and Wireless' started by bgk62, Jun 27, 2018.

Scroll to continue with content
  1. bgk62

    bgk62

    9
    0
    Jun 22, 2018
    I am doing an upgrade on this amp. and matching power supply ,It has two 3-500z Eimac tubes ,Connected too the anode of each tube is a paracitic suppresser with 2, 220 ohm 2 watt carb. comp. resisters ,twisted together in paralell.with a silver strap wraped arround them ,I wanted to check the resisters to see if they needed to be replaced and all looked like they have endured high levels of heat ,so I tryed to check the resistance with my ohm meter and they show no resistance at all ,There are two tubes yn this amp and both suppressers show no resistance ,I took both of them out of the circiut and same thing maybe I need to remove the resisters from the metal strap ?can anyone tell me what the deal is with these things???? BK
     
  2. 73's de Edd

    73's de Edd

    3,050
    1,289
    Aug 21, 2015
    Sir bgk6 . . . . .

    I would change them all out, since at higher frequencies operation, the increasing inductance reactance of L4 and L5 will have them sharing more power thru them. Definitely stay with CARBON COMPOSITION types for replacements..
    You say
    " they show no resistance at all "
    Now is that a zero resistance / short . . . .IF . . .you haven't pulled them out of their shunting L4 and L5 inductors ( your " metal strap" ) circuitry to test.
    Or is that being infinite resistance / open circuit ? . . . . when pulled out of circuit . . . in which case, they REALLY have been damaged.
    Hi power RF does funny things over a period of time.


    73's de Edd
     
    Last edited: Jun 27, 2018
  3. bgk62

    bgk62

    9
    0
    Jun 22, 2018
    I have pulled L4 andL5 out of the amp. but they are still soldered to the shunting. the meter reads 000.00 as if I touched the probes together.
     
  4. bgk62

    bgk62

    9
    0
    Jun 22, 2018
    I can get Alan Bradley carbon comps. at Nebraska surplus sales Thanks again Edd.
     
    Last edited by a moderator: Jun 27, 2018
  5. kellys_eye

    kellys_eye

    4,275
    1,146
    Jun 25, 2010
    If they are still soldered to the shunt then they WILL show 0.00Ω - you need to remove them from the shunt to do a proper resistance check.
     
  6. bgk62

    bgk62

    9
    0
    Jun 22, 2018
    EDD.I went ahead and unsoldered the resisters from the shrouds and took another reading one was 79.3 ohms and the other was 83.0 so I think they are supposed to be 73 ohms I think thats close enough .
     
  7. bgk62

    bgk62

    9
    0
    Jun 22, 2018
    Shunts
     
  8. kellys_eye

    kellys_eye

    4,275
    1,146
    Jun 25, 2010
    Is there a known 'fault' with the amp/PSU? or are you just 'renovating'?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-