Connect with us

Sony TA-1055 - Right tuner channel problem

Discussion in 'Troubleshooting and Repair' started by vviston, Mar 16, 2019.

  1. vviston

    vviston

    2
    0
    Mar 16, 2019
    Here is the scenario:

    I have Sony TA-1055 amplifier and Sony ST-5055L and Sony ST-5066 receivers. First I have bought ST-5066 and everything seems to work fine. I don't use the tuner very often. Then I realized that ST-5055L is the "right" tuner for my amplifier so I bought it as well. But with this receiver only left channel worked. The right channel works only if I set the volume to the max and even with this setting I have got only a little sound. So the right channel is very very weak/poor.

    So I thought that the receiver is the problem. I plugged in the ST-5066 receiver back and when I examined it more closely the right channel output is better than with ST-5055L but still maybe 3 times lower/weaker than left channel.

    So my final suspicion it that my amplifier is wrong. Only thing I am not able to answer is why one tuner has better (but still weak) output on the right channel than the other? I use is for AUX music via jack and both channels are equal. So the problem is in the amplifier's tuner right channel. Can someone help me with this problem? Maybe there is some well known error with this amplifiers or something like that.

    Thank you!

     
    Last edited: Mar 16, 2019
  2. vviston

    vviston

    2
    0
    Mar 16, 2019
    UPDATE: I changed the cables on the receiver with the working channel and both speakers worked. It means the amplifier works fine with both channels. So I should redefine the topic - I need to help with ST-5055L repair - right channel doesn't work.

    Thank you!
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-