Connect with us

Sony KV-29F2U Repair

Discussion in 'Electronic Repair' started by Web Master, Aug 31, 2004.

Scroll to continue with content
  1. Web Master

    Web Master Guest

    Hello,

    I have a Sony KV-29F2U which has been working fine for a good many
    years, but since the last few months it has been taking longer and
    longer to come on. i.e you would switch it on and it would take at
    least a minute for the picture to come on if not more also the picture
    looks more blured these days.

    Does anyone know how to fix this ?

    Thanks in advance
     
  2. JVC dude

    JVC dude Guest

    Sounds like the tube emmission failing.
    take it to a dealer who has a booster/rejuvenator who can try to
    clean/balance the guns etc up.
    Its a 50:50 case. If the guns are so low then only a new tube will cure it.
    sometimes the booster can end the tube also
    so you only do it when all else is lost, but worth a try
    AW
     
  3. b

    b Guest

    Before going on to things like tube rejuvenation etc, first try
    replacing all caps in the high voltage lines, and those near the line
    output transformer, typically rated about 160v. These are usually the
    components which suffer with age and heat and are not expensive to
    replace.
    Good luck
    Ben
     
  4. Web Master

    Web Master Guest

    Thank you for your help
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-