Connect with us

Sony CDX-705 10 CD Changer

Discussion in 'Troubleshooting and Repair' started by desrv1, Jul 18, 2011.

Scroll to continue with content
  1. desrv1

    desrv1

    2
    0
    Jul 18, 2011
    I joined the site for some help. I have a Sony CDX-705 CD changer in my 1998 motorhome. I can't get the CD Magazine to eject so all 10 CD's are stuck in the unit. I can get the unit out of the dash, but don't know what to do once I get it out!
    I'd prefer to repair or replace so I don't leave a large hole in the front of my dash. Is it worth repairing and if not, I also have a good Pioneer 6 CD changer from a car I sold years ago. Problem is, it doesn't fit the space in the dash. If I should use that one, is there an adapter cable that would attach to the Sony cable that is there already?
    Thanks, desrv1
     
  2. nepow

    nepow

    99
    1
    Jul 18, 2011
    Once out of the vehicle you can remove the covers to reveal the cause of the failure. Take your time and don't force anything...may be a jammed cd? also take a look to see if the laser transport is jammed. Not familiar with this model, but some laser chassis assemblies move up to meet the loaded cd and can get stuck upon returning caused by a slipping drive belt!! at worst the fault could be a mechanism timming error... gears or drive commponents moved out of sync. Lastly try "Google" enter the model, could be a common fault? Best of luck Nepow
     
  3. desrv1

    desrv1

    2
    0
    Jul 18, 2011
    Problem solved

    Thanks for your response. Since I posted the questions, I checked in the owners manual and it said that if I had unhooked the coach battery terminal, I should press the reset buitton on the Sony Radio. I did that, but, it didn't immediately fix the problem. Fortunately, I had the CD player out of it's spot in the dashboard and I "lightly" (as you suggested) moved it around and jiggled some parts. The magazine did finally eject. I took out the CD's in case it got stuck again. I found one CD that had been put in upside down. Took them all out and replaced several of them slowly and carefully. Tried ejecting each time I added one. Everything started working normally and I put the dash back together.
    Hopefully it will continue to work nomally!! Thanks again for your help.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-