Connect with us

Solve noise for Amplifier board.

Discussion in 'Electronic Design' started by Chauny, Apr 20, 2007.

Scroll to continue with content
  1. Chauny

    Chauny Guest

    Hello peaple,

    I make a amplifier circuit with TDA2030, the amplifier works but when
    i connect it to loudspeaker, turn on the power, i hear noise from
    loudspeaker without input. I can not solve this problem although i
    make layout with center ground.
    Could anybody help me solve this problem?

    Regards,
    Chauny.
     
  2. describe the power supply please


    martin
     
  3. Eeyore

    Eeyore Guest

    What kind of noise ?

    Graham
     
  4. mpm

    mpm Guest

    I agree. Sounds like a power supply issue.
    I would look there first.

    Can you describe the noise it is making?
    Static, high-whine, low-rumble, something else??
    Also, how loud is the noise, and what sound(s) are you trying to
    amplify?
    Speech? Music? Simple tones?, a combintation?
    And while you're at it, what kind of speaker?
    -mpm
     
  5. D from BC

    D from BC Guest

    When you press your ear against the speaker, try not to move your ear
    around..That will make a rubbing noise.. :p
    D from BC
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-