Connect with us

Solid ground plane with ORCAD LAYOUT

Discussion in 'CAD' started by David, Oct 8, 2008.

Scroll to continue with content
  1. David

    David Guest

    Hi everyone!

    I'm having problems with Orcad Layout. I've desgned a PCB for my
    company and I've sent the GERBER files to the factory. But the factory
    operator said me that the ground planes I've created on my design
    aren't solid planes and they must be solid planes.

    My idea was to use all the unused PCB surface to make the ground
    tracks bigger, so they take all the space available where there are
    any tracks. Therefore I've place a big copper pour obstacle associated
    to the ground net. The result seems to be really good, I mean I can
    see a lot of copper areas going around the tracks.

    But the factory guy said that, actually, the copper obstacles are made
    of thousands of little tracks (about 75000 tracks!!). So they just see
    a lot of tracks instead of a real copper area despite it seems a
    homogeneous area. But this is a problem for the PCB's machine.

    Somehow I needto tell Orcad that the copper pour must be a continuous
    and homogeneous area.

    Could you help me? I need to work out with this problem now!

    Regards
     
  2. qrk

    qrk Guest

    The copper pours are normally made up of many draw lines. You can
    control the number of lines by specifying the width of the line in the
    obstacle dialog box. Somewhere in the 5 to 10 mil width is good. If
    your design isn't crowded, then you can use a wider width like 20
    mils.

    Also, be sure that your plane is set to solid. There are other options
    in the obstacle dialog which let you set hatched planes for copper
    robber patterns.

    You should be able to preview what Gerber data looks like with
    GerbTool which comes packaged with certain versions of Layout
    (Tools|GerbTool). If you don't have GerbTool, download one of the free
    Gerber viewers to see what your board really looks like. If fact, you
    should always view your Gerber data before sending it out to be sure
    that the Gerber data matches what you think you should have.

    Be sure to set your copper pour preferences in Options|User
    Preferences to Enable copper pour and use pours for connectivity. Fast
    mode and skeleton display should be turned off. Layout will bugger the
    copper pours if copper preferences aren't set up correctly.
     
  3. David,
    The key question here, why is the "factory guy" telling you what he is
    telling you? I think there may be some confusion about his comments. You are
    interpretting it that the copper polygon should be solid (not drawn from
    individual lines) but I would bet he is calling for a solid ground plane
    within the board (a multilayer board design). What you have described about
    your design is quite normal for a lot of designs, designs use a poured
    polygon GND flooded over the unused areas of the design quite often. And the
    multitude of individual lines making up that polygon pour is quite normal
    also.

    But why is the factory telling you what to do? Just fishing here because
    the relationship sounds a little funny the way that you have stated it in
    such limited detail.
    Do your GND connections make connections to all GND points without
    breaks? Do your OrCAD DRC checks report any incomplete routes/connections?

    Do you have any controlled impedance lines called out? That could be a
    problem causing such a request from the factory guy. You can't have
    controlled impedance without a contiguous associated plane directly below or
    above your trace. If you have controlled impedance in this design then you
    obviously don't understand the requirements for impedance controlled lines
    and the factory guy knows you need a contiguous internal plane to achieve
    the impedance control for those lines.
     
  4. Guest

    David

    Another possibility is the kind of gerber's that you have created. the
    gerber format is basically "drag shape x from point a to point b". x
    can be defined in the file or in a seperate file depending on gerber
    type.

    Orcad is really irritating in not creating a sub-directory for output
    files, you may have not sent him the "x" definitions.

    Colin
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-