Connect with us

Si826x gate driver keeps failing

Discussion in 'General Electronics Discussion' started by Carel, Jun 4, 2017.

Scroll to continue with content
  1. Carel

    Carel

    11
    0
    Jun 21, 2009
    Hi,
    I'm having a problem with an isolated half bridge driver circuit where the gate driver keeps failing.

    I'm trying to use two "Si8261BBC-C-IP" isolated gate driver ICs to isolate the MCU from the MOSFETs, but the driver keeps failing after less than 1 minute. As soon as I replace the component with a "FOD3180TV", the circuit works for more than one hour. The MOSFETs however are fine as well as the MCU. It's just the gate drivers that keeps on failing, especially the low side driver.

    At this stage I'm only building a test circuit which is running at about 50-kHz and a 40 % duty cycle and a resistor as a "load".

    I would really like to have someone just look at my circuit diagram and make a suggestion as to what might be wrong or what I might improve on. The problem is that the gate driver keeps failing and I just simply cannot understand why and what is wrong. The output of the circuit (as measured on an oscilloscope) seems to be a perfect square wave.

    Any advice would be greatly appreciated.

    Kind Regards
     

    Attached Files:

  2. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,482
    2,830
    Jan 21, 2010
    What is the failure mode?

    Is it U1 or U3 that are failing (or both)?
     
  3. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,482
    2,830
    Jan 21, 2010
    My first thought was that the SMAJ28CA-E3/61 was conducting and loading down the rail (which is just a 10μF cap), but this is a 28V device. Incidentally, it is rated to allow 28V across it. It clips at 31V or more. This is higher than the Vgs(max) (30V) and also significantly higher than the supply voltage (15V). My recommendation would be to use a 20V device.

    I note that the FOD3180 requires a 0.1μF cap across its supply pins. You don't have this, and you don't say what type the capacitors C1/C2/C4/C5 are. If the 1μF is ceramic, and if it is close to pins 5 and 8 of the driver it should be fine, otherwise I'd add a 0.1μF cap across the supply pins.

    You gave a very high Rg (20Ω) so the maximum current these drivers would be called on to supply is less than 1A, so that's not a reason for failure (the Si826x is rated for up to 4A, the FOD3180 for 2A).

    The supply current for the FOD3180 is greater than for the Si826x, so if the fault is caused by by discharging the supply caps then (a) only U3 would be affected, and (b) the FOD3180 would lower the voltage faster.

    I can't see anything obvious. Perhaps knowing whether one or both fail, and what their failure mode is will give a hint.

    Oh, and when you say that the FOD3180's run for an hour, I assume you mean they don't fail, and you gave up testing after 1 hour.
     
  4. Carel

    Carel

    11
    0
    Jun 21, 2009
    Hi, thank you very much for all of the replies and interest of helping me.

    I couldn't remember whether its the low side or high side driver that keeps failing. I think it is the low side one mostly, but I do remember that at one stage I had to replace both. The thing is I don't see anything obvious and it fails before I can properly measure everywhere I would want.

    All capacitors are electrolytic, but I seriously doubt that only that can be the difference between night and day, since there are a 0.1 and 10uF capacitor in parallel. Both are electrolytic, but I did however measure the Vcc-GND pin voltage and that remained constant. Both caps are right next to the driver.

    The reason for the high gate resistor is because I were trying to figure out if it is maybe di/dt's that causes failure. The original ones were 4.7 ohm, but even with the 20 ohms, they still fail. They do however seem to last about 30s longer with the 20 ohm resistor than with the 4.7 one.

    Lastly, yes. The FOD3180 ran only for one hour, I didn't continue to test it further because it wouldn't fail.

    I will try to do measurements everywhere in the circuit somewhere in the week using the FOD3180's.

    I'm planning on measuring the following (maybe someone can give me hints to what I can add to this list):
    1.) Gate driver supply di/dt's (current waveforms as drawn by the driver on Vcc) and voltage
    2.) Gate driver output (voltage waveforms)
    3.) Gate resistor di/dt's (current waveforms)
    4.) The effect of different loads on all of the above
     
  5. Alec_t

    Alec_t

    2,940
    799
    Jul 7, 2015
    I have replied over at ETO.
     
  6. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,482
    2,830
    Jan 21, 2010
    It sounds like you've done a lot of sensible things to troubleshoot the problem.

    Have you programmed dead time between turning one mosfet off and the other on? If you haven't, it is possible to have a brief high current pulse going through both MOSFETs. This typically causes some heating though.

    If this is happening you can have both wired inductive stuff happening as well as voltage spikes appearing on the gate due to capacitive coupling. Replacing the gate protection device with a simple 16V zener might help -- at least to diagnose the issue.

    If I have time I'll take a closer look at the datasheets again to see if they disclose any differences in the protection.
     
  7. Carel

    Carel

    11
    0
    Jun 21, 2009
    I did some further testing. I added a load to the half bridge stage and saw that when no minimum load is present, the gate drivers will fail immediately. With a minimum load drawing at least 0.5 A, they don't fail anymore.

    Just other things I do note. This board is just a prototype or rather a prototype of a prototype. In the past I've always used gate drive transformers or a regular gate driver IC like IR2110, this is just something new I wanted to try instead as it can simplify and shrink the circuit significantly. So yes, I agree that a 0.1uF cap is needed, but I don't think this is the primary cause for them failing. For final stage implementation - Yes, I will certainly add them, for a prototype - NO. I will explain this just now.

    I tested the Vcc-GND voltage across each driver (High and Low Side) on the scope. There was no detectable ripple at all. If the omission of the 0.1uF cap or the electrolytic caps having a high ESR and inductance was the cause, then I would've seen some voltage spikes, however I saw zilch. Second reason is that the driver output stage always seemed to NOT be shorted across Vcc-to-GND but rather between Vout-to-Vcc or Vout-to-GND. This tells me there are spikes coming from the MOSFET gate causing the schmitt-trigger FETs to fail.

    I measured the voltage across the 20-ohm resistor and I saw some very high spikes when I remove the load of the half bridge. This decreased when I increased the load. Peaks reached about 9-10V over the 20-ohm resistor, indicating about 0.5A peaks. The driver states that it can handle 4A peaks.

    Last thing I noticed. I did a torture test on the two drivers. One is FOD3180 (2A peaks) and the other SI8261BBC (4A peaks). I found something very, very interesting. I added random caps in increasing numbers and sure enough, the FOD3180 could handle spikes of up to 2A (remember I'm talking about peak spikes of very, very short duration). Over that and it would fail. However, the SI8261BBC barely managed over 0.9A (peak) before it fails. I don't get it as to why since they're supposed to be stronger.

    However something else I'm seeing is that When the low side FET is switching, it's highly detectable on the gate of Q1, causing about 200-250mA to be sink/sourced by its driver, which must not be the case. The opposite is also true. I haven't got the time yet to figure all of that out yet, I'll read through the whole PDF that Alec_t posted sometime tomorrow.

    In the 1st image, this was measured on the PWM generator for Q1 (just to show when what switches and the dead time). Then the 2nd image shows the voltage over Q2. It doesn't matter whether its high or low side, they both look the same. I'm assuming this can cause me potential further problems. I'll probably look into it in the coming week.

    I should add that the MOSFETs which I'm using is IXTH48N65X2, which are very low RDS(ON).
     

    Attached Files:

    • 1.jpg
      1.jpg
      File size:
      62.9 KB
      Views:
      73
    • 2.jpg
      2.jpg
      File size:
      68.1 KB
      Views:
      82
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-