Connect with us

Sharp vcr a-50 player wont play tape

Discussion in 'Troubleshooting and Repair' started by joudy, Apr 27, 2018.

Scroll to continue with content
  1. joudy

    joudy

    1
    0
    Apr 27, 2018
    hello , i have a very old sharp vcr a-50 player that i decided to play again but the problem is the tape doesn't appear when i press play (theres no picture on the tv ) but when i press rewind or fast forward it appears as it rewinds\forwards , how can i solve this ?
     

    Attached Files:

  2. kellys_eye

    kellys_eye

    4,275
    1,147
    Jun 25, 2010
    Check for broken or stretched belts on the internal mechanism.

    TBH an old VCR is a combination of complex electronics with even more complex mechanics - not something that anyone of little experience would have luck in repairing. This is likely to be a professionals task and a rare (ish) professional at that.

    If the fault is more extensive than broken/missing/stretched belts then I'd suggest you dispose of the unit.
     
    joudy likes this.
  3. shrtrnd

    shrtrnd

    3,814
    516
    Jan 15, 2010
    I'd try a tape head cleaning tape, although kellys-eye is probably right that it could be something else that would be expensive to have fixed. If the heads inside, that the tape runs across are coated with material debris from previous tapes being run over them, sometimes that causes the tape you're trying to play problems being read.
    Just a last-ditch easy to do attempt that I would make.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-