Connect with us

Seven segment display odd issue

Discussion in 'Troubleshooting and Repair' started by STRIKER10836, Mar 17, 2019.

  1. STRIKER10836

    STRIKER10836

    3
    0
    Mar 17, 2019
    I am trying to repair a treadmill display issue. The seven segment displays show all on but when I place my hand close but not touching over it works. There is no function issues whatsoever. Could it be crystal clock is the issue? I have checked the grounding.



    I have not seen this issue before
     

    Attached Files:

  2. davenn

    davenn Moderator

    13,139
    1,704
    Sep 5, 2009
    show an underside photo of the board as well so solder joints etc can be checked
     
  3. Bluejets

    Bluejets

    3,288
    652
    Oct 5, 2014
    Left top to centre looks like some liquid spill on the board at some time.
     
  4. STRIKER10836

    STRIKER10836

    3
    0
    Mar 17, 2019
    Attached is the underside. There is globs of glue that look like someone previously removed. As stated looks like was some signs of a liquid but no corrosion. Not sure why the display would work normally if i hover my hand over the display.
     

    Attached Files:

  5. Bluejets

    Bluejets

    3,288
    652
    Oct 5, 2014
    Another look at the video it seems all the displays are affected.

    Also, where you are passing your hand is directly over the crystal.

    Anything obvious there....?
     
  6. STRIKER10836

    STRIKER10836

    3
    0
    Mar 17, 2019
    Yes, it does seem that when my hand was over the section with the crystal all the displays work. I even tried while not standing or touching the equipment. I think I may replace the crystal. But wanted to check in to see if anyone has seen and resolved this type of issue
     
  7. Bluejets

    Bluejets

    3,288
    652
    Oct 5, 2014
    Don't think that necessarily means a crook crystal.
    Placing your hand over the area is more a capacitive effect.
    I'd still be looking a bit further into that "apparent" liquid spill. and as Davenn says, crook connections somewhere.
     
  8. Bluejets

    Bluejets

    3,288
    652
    Oct 5, 2014
    Do you understand how multiplexing works as it will help you to find your problem...??
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-