Connect with us

Seagate 160GB IDE drive suddenly invisible.

Discussion in 'Electronic Repair' started by David Farber, May 13, 2010.

Scroll to continue with content
  1. David Farber

    David Farber Guest

    I use my generic, home made, pc to test and analyze client's hard drives.
    The motherboard in my pc is an ECS NFORCE3. It's never given me any
    problems. When I hooked up the test drive in question (lots of knocking
    noises) on the second IDE channel, the pc booted, the pc speaker beeped once
    (normal for this pc), but it just froze after that. I rebooted and tried to
    go into the setup menu but that didn't work either. I gave up on the test
    and removed the drive I was checking. But now, the same problem occurs. The
    pc powers up, speaker beeps, and it freezes there. If I press "delete" to
    enter setup, it just hangs without going into setup. If I remember
    correctly, immediately after removing the test drive, I was able to get to
    the bios menu but it said no drive was installed. I used the internal clear
    CMOS jumper to reset the bios but the outcome was the same. Now, I am not
    even able to get that far. If I put in any other drive, I am able to access
    the bios menu and the drive is recognized correctly. I was not having any
    problems with the drive before adding the test drive on the secondary IDE
    channel. I can feel the motor humming when the machine is powered up. I've
    tried switching between "cable select" and "master=on, slave =off," that
    didn't help. There are no clicking or foreign noises. I was hoping to
    purchase a used drive of the same model and swap out the controller boards.
    My question is, how close of a match do these boards have to be? So far I
    have found the same drive model number and firmware code, but a different
    HDA p/n. Anyone have any luck doing a swap like this? Is there some
    identifying data on the hard drive platters themselves that would cause the
    drive to "disappear" like this? I did try the drive in another pc. It gave a
    similar error, "Drive not detected," and asked if I wanted to bypass the
    detection process.

    Thanks for your reply.
     
  2. D Yuniskis

    D Yuniskis Guest

    Hi David,

    I.e., WITHOUT DRIVE your PC is not operating properly!
    A few sentences ago, you claimed the PC doesn't get to BIOS with the
    "bad" drive disconnected. Now it *does* (with a different drive)?
    Are you sure your descriptions are consistent?
     
  3. David Farber

    David Farber Guest

    Sorry if the description wasn't clear. Let me try to list the chain of
    events.

    1. Pc works fine with Seagate drive as master drive on first IDE channel.
    2. Installed another hard drive to test as master on secondary channel.
    3. Pc freezes while trying to list attached drives. Cannot access bios
    screen.
    4. I remove the drive on the secondary channel.
    5. At some point I think I was able to get into the bios menu after removing
    the test drive but at that point, it indicated no drive was present.
    6. After a couple of more tries, I cannot get to the bios menu anymore.
    7. I tried different jumper settings on the Seagate drive and clearing the
    CMOS. This didn't solve the problem.
    8. Substituted another drive just to see if the Seagate drive was causing
    the problem. No problems with a different drive installed. Drive is
    recognized properly.


    Thanks for your reply.
     
  4. D Yuniskis

    D Yuniskis Guest

    So, there was still a SEAGATE on channel 1 master (?).
    And, with *no* drive on channel 2, it CORRECTLY tells you
    "no drive present" (on channel *2*?).
    Suggesting that the seagate on channel *1* is your problem?
    (or, something in the PC/PS)
    This is the channel 1 seagate that you have now replaced, correct?

    I.e., all of this seems to indicate the seagate channel 1 master
    is the issue (?)

    Have you tried putting that drive on anywhere *else* WITH THE
    "different" (working) drive installed?

    Note that some drives have different jumper settings for
    "master" and "master with slave present". The BIOS can
    "hang" for quite a while (almost a minute) looking for a
    slave that it *thinks* is there -- but isn't.
     
  5. David Farber

    David Farber Guest

    Yes, that is correct.
    I tried the Seagate on another pc connected to the second channel. The pc
    hung trying to detect the drive. There was a working drive on the primary
    channel.
    I waited for a while. Probably two minutes. No go.

    Thanks for your reply.
     
  6. Franc Zabkar

    Franc Zabkar Guest


    If the drive spins up but is not detected, then the fault is most
    likely inside the HDA (head/disc assembly). However, I have seen cases
    where a bad IDE cable produces the same symptom. That said, if you
    decide to replace the circuit board, be prepared to transplant the
    serial EEPROM (flash) chip from patient to donor. On newer models this
    chip stores unique drive specific calibration data.

    See the following article for help in identifying the components.

    HDD from inside Main parts:
    http://hddscan.com/doc/HDD_from_inside.html

    The following article explains why drives have "adaptive" data.

    HDD from inside: Tracks and Zones. How hard it can be?
    http://hddscan.com/doc/HDD_Tracks_and_Zones.html

    Essentially the reason is that no two heads are physically identical.
    HD manufacturers try to fit as much data as possible onto each
    platter. To do this, they take advantage of any head that performs
    better than the average.

    For example, some heads will have a better frequency response than
    others, which means that you can cram more bits on each track. This
    technique is called Variable Bits Per Inch (VBPI).

    Giant magnetorestive (GMR) heads use a separate element for writing
    and another for reading. The separation between these two components
    varies from head to head. Once again manufacturers optimise data
    density by implementing Variable Tracks Per Inch (VTPI).

    Each HD therefore needs to be calibrated to account for VBPI and VTPI,
    otherwise the drive doesn't know where to find the tracks, or the data
    within the track. When a drive powers up, it needs to retrieve the
    bulk of its firmware from a reserved area (System Area) on the
    platters. If it can't read these data, then it clicks. This is what
    usually happens after you swap a board without transferring the
    calibration information.

    - Franc Zabkar
     
  7. Adrian C

    Adrian C Guest

    How long ago? The drives will have a warranty with Maplin, but if the
    shop staff act like the stupid berks they normally are, you should be
    able to ship them back to Seagate. You can check warranty status on
    their web site.
     
  8. PeterD

    PeterD Guest

    Still not really clear... #1 above says the computer works OK with the
    Seagate drive.
    #7 says it doesn't work OK with the Seagate drive.

    I'd think you have a bad cable, or you broke the drive.

    BTW, you can't 'swap' the controller cards between drives, the NV ram
    on the controller is programmed to the drive itself.
     
  9. David Farber

    David Farber Guest

    Yes! Exactly. That would have prevented the problem completely which was...

    I've slid so many test drives in out of the drive bay that occasionally the
    test slave drive doesn't go in exactly straight and clips the bottom of the
    Seagate drive. After closer inspection of the Seagate controller board, I
    found a capacitor hanging by one terminal, a zero ohm resistor which had a
    cold solder joint, and another capacitor missing from the board. There were
    just a couple of pc pads with only some leftover solder to show for it. All
    these parts are very small smd components and that's why I missed it on the
    first couple of go-rounds. Fortunately, I had another Seagate drive with the
    same controller layout. I used it to supply the missing capacitor. Soldering
    was not easy at all as I tried to hold the part in place with a tiny
    screwdriver. The magnetic field from the drive must have transferred to the
    capacitor (or my tools have been around too many speaker magnets) because
    the screwdriver was totally useless in aligning it to the board. I wound up
    using a wood stick from a broken off Q-tip to hold it in place.

    Anyway, the drive boots fine now. Next step is to backup the drive. I get so
    involved in backing up and restoring other people's data I've neglected
    doing the same for myself.

    Thanks for your reply.
     
  10. David Farber

    David Farber Guest

    Good call about the "broken" drive. I broke it moving it around. See my post
    a little way down the list.

    Thanks for your reply.
     
  11. David Farber

    David Farber Guest


    Great info Franc. However I'm glad I didn't open the drive. That certainly
    would have ruined it for good.

    As it turns out, the drive suffered a "clipping" problem. See my post a few
    messages after this one in response to Chris Oates.

    Thanks for your reply.
     
  12. Jamie

    Jamie Guest

    Oh it's clear to me.
    the first drive is the master to start with, second one as a slave
    which he in stalled. The slave connects with the master.. There is
    something seriously wrong with the slave, it has destroyed or rewritten
    some vital parameters on the master drive. The controller on the master
    needs to be corrected..
    Also, a true electrical failure may existed on the failed drive that
    has now shorted the once working drive, which was the primary (master)..


    When testing drives, its always a good idea to boot from a external
    device to get your test PC running. Put the test drive in as a master.
    Don't have any other drives connected to that channel..
     
  13. PeterD

    PeterD Guest

    An amazing diagnostic and repair... I'm impressed you were able to
    recover.
     
  14. Meat Plow

    Meat Plow Guest

    WHEW what a read. Put a known good drive on the dead drive cable. If CMOS
    enumerates it then the drive electronics are hosed and you can either
    toss it, try to find an exact working drive and swap the control board or
    send it off to a recovery service if it has data on it you can't do
    without.
     
  15. David Farber

    David Farber Guest

    Do you mean what a good read or what a bad read? Do I have a career in store
    as a technical writer? lol. Anyway, you were right about the electronics.
    See my post from yesterday. A few of the smd parts on the pc board got
    knocked off from sliding test drives into the tight fitting drive bay
    underneath it. I happened to have had another Seagate drive to use for
    parts and now all is well.

    Thanks for your reply.
     
  16. Meat Plow

    Meat Plow Guest

    LOL Yes your description was very verbose. I'm glad you got a resolution
    using the method described. However, I {think} drives have writable flash
    memory that is used by the manufacturer to map things like engineering
    tracks and the likes so the possibility may exist that you would end up
    with slightly less capacity or some other anomaly by the swap. Of course
    this is pure speculation on my part but it is born of reading something
    in the past and may not apply to new(er) drives. I have done exactly the
    same thing with and old Conner RLL drive many moons ago and it did work.
    Back then before IDE appeared on the consumer shelf drives were horribly
    expensive and anything one could do to salvage a drive was well worth the
    effort.I can remember waiting hours, even days for Gibson Spinrite to try
    to move data from damaged to good clusters and map those clusters out as
    bad only to find out it stayed at 30% done for 30 hours :)
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-