Connect with us

Samsung multifunction: scanner error

Discussion in 'Electronic Repair' started by SparkyGuy, Mar 7, 2007.

Scroll to continue with content
  1. SparkyGuy

    SparkyGuy Guest

    Lightly used Samsung SCX-4100 multi.

    When powering on, LCD display says "Warming Up Please Wait" while the fuser
    heats up. Meanwhile the scanner carriage does a quick "zero" just out a few
    mm's and back, but continues to run the carriage motor endlessly, banging
    against the zero stop until it gives up and puts up "Scanner Error" on the

    I got one good copy from it when it didn't do the "infinite zeroing" thing,
    so I know it can work.

    The scanner carriage is just a piece of tin with the plastic bulb/camera
    holder, riding on a single rod. A toothed belt runs around the motor drive
    gear and a spring-loaded tension gear at the end of the run. The belt is
    simply "pinched" in a groove in the plastic bulb holder. When the carriage is
    run up against the zero stop, the motor keeps going and the belt slips
    through this groove.

    I presume that this is the way it was designed to zero the carriage, just
    running the motor long enough to run the full length of the bed and stop. But
    it doesn't stop until it gives up.

    There is no "home" sensor. No magnet, no opto, nada. Just a metal tab on the
    carriage that bangs against another at the top of the run.

    I tried holding the belt still, thinking that maybe the motor current is
    monitored and when it goes high, that's zero. But the motor (a stepper) just
    skips sync, and tries to keep going.

    The under side of the glass has no marks that might be used for zero
    indication by the camera.

    I checked ground (it's tight) and for routing of the data cable from the
    scanner carriage (it goes through its huge ferrite bead).

    How do these el-cheapo models determine zero position?

    Where might I look for a problem?

    Yes, I know it's cheap. But if I can keep it out of the landfill and have a
    simple document scanner, that would be great.

  2. webpa

    webpa Guest

    On cheap and expensive machines, zero position is usually determed by
    a led-pt (phototransistor) pair or assembly. These sometimes have
    tiny aperatures that become blocked by ambient hair (pet-human-etc).
    Find your sensor pair and clean it. If still no joy, look at the
    assembly with a video camera or still camera...their sensors can "see"
    IR emitters very clearly (verify this with any working TV remote
    control). If you don't see the emitter shining: Fix it.
  3. SparkyGuy

    SparkyGuy Guest

    On cheap and expensive machines, zero position is usually determed by
    I've disassembled the scanner completely. There's no place for an opto (if it
    existed) to be "interrupted" (by a tab or such). There's nothing but a long
    rectangular plastic holder that has a long pcb glued on the bottom and the
    lamp and camera elements within. (Surprise! When I removed it and turned it
    over, there was a label: "Canon". The flex cable connects to the pcb.

    Used a digicam as you suggested. Nothing other than the exposure lamp.

    It's still a puzzle how it registers ("zeros") let alone what's

  4. Lionel

    Lionel Guest

    Could be using the CCD itself to detect a pattern underneath the lid
    of the unit, just before the start of the glass sheet. That's how a
    lot of them do their lamp check. Try looking for patterns or black
    marks on the underside of the housing that surrounds the glass.
  5. SparkyGuy

    SparkyGuy Guest

    Could be using the CCD itself to detect a pattern underneath the lid
    I thought that might be the case. Just beyond the clear glass area (in the
    "home" end of the glass) is this pattern of white and black (view in
    mono-space font). Area within lines is white:

    __________ ___________ ___________
    | |__________| |__________| |

    I cleaned the glass. What else to do? If it's not "reading" this pattern,
    could indeed be the reason its not "zeroing".

    I'm guessing the ccd is toast. Or one of the traces on the ribbon cable (one
    of those mylar PC affairs) broke.
  6. Lionel

    Lionel Guest

    I'd say that's almost certainly the case. You might check of
    misalignment of the sensor, or for something interfering with the
    light path from the lamp to the pattern, to the sensor.
    I've never seen a totally bad CCD. The golden rule of electronic
    equipment diagnosis is that 90% of faults are due to bad connections
    of some sort, & 90% of those connection faults are in moving parts.
    I'd trace the path around the flat cable, starting from the joints on
    the main board ribbon connector, right through to the joints on the
    corresponding connector on the CCD board.
  7. SparkyGuy

    SparkyGuy Guest

    There's no "sensor", per se, in this design, is there? I mean, the pattern on
    the underside of the glass that marks the end of the "page" region is read by
    the CCD and interpreted as "home", right? No sensor, cheap to do in software.
    Or am I not understanding something? (always a possibility (c: )
    I ohm'd out the cable. Tests good.

    Looks like the CCD has died. Well, the printer is "ok", but not great. It'll
    be fine for text (albeit single-sided). Have inkjet for image printing.

  8. Lionel

    Lionel Guest

    By 'sensor', I meant the CCD, as we've already confirmed that the unit
    doesn't have a dedicated home position sensor.
    Your unit obviously uses the black & white pattern as both a home
    position sensor & a white-level reference, & does both in firmware.
    (And yes, back in the old days, when an 8048 CPU & a 2716 (2KB) EPROM
    were the second & third most expensive chips in the scanner, it was
    cheaper to use dedicated sensors to detect home position, rather than
    a handful of EPROMS. ;^)
    Anyway, I was referring to the possibility that the CCD might be out
    of optical/mechanical alignment with the 'home position', or might
    have dirt/dust on that end of the CCD, which might screw up the
    pattern detection.

    The latter is a very common failure mode, BTW. And those tiny clip
    down connectors for the mylar film cables pop open/loose *very*
    easily, especially with vibration. Back when I fixed Toshiba laptops
    for a living, those bloody connectorss were the single most common
    cause of screen failures (after accidental breakage), because the LCD
    modules use as many as eight of those ribbons to connect the
    pixel-drive controller boards to the actual glass, & when one came
    loose, part of the screen would go dead. The best fix turned out to be
    re-clipping the ribbon firmly & then taping across the clip & part of
    the ribbon with fibreglass tape, a procedure that Toshiba eventually
    started doing at the factory.
    From the connector, or from the ribbon itself?
    My pleasure. Even if it hasn't gotten your scanner going, maybe
    someone will have found the discussion educational. ;^)
  9. SparkyGuy

    SparkyGuy Guest

    Anyway, I was referring to the possibility that the CCD might be out
    If its out of alignment, there's little I can do; it's a plastic assembly
    riding on a polished rod. Not a precision fit, and no adjustment I can see...

    I never cleaned the CCD assembly, but what have I got to lose? I'll take some
    alcohol to it and see what happens.
    Did Toshiba give you credit for the fix? (c: Well, at least the world now
    knows the Lionel designed it! Take note, world!!
    Ribbon only. I'll attempt to test across the connectors next.
    And with the added bonus of USENET's "forever" archive, your advice is
    recorded for future generations (c:

    Thanks again,

  10. Lionel

    Lionel Guest

    No, because I didn't invent it. ;) Somebody at Toshiba came up with
    the idea of using glass-tape, & multiple people in the field (myself
    included) tried different variations on that theme to improve the
    reliability, so my contribution wasn't all that big.
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day