Connect with us

RS422 RJ45 loopback cable

Discussion in 'Electronic Basics' started by [email protected], Oct 20, 2006.

Scroll to continue with content
  1. Guest

    I created an RS422 RJ45 loopback cable by connecting pin 1 to pin 8 and
    pin 4 to pin 5.

    I also connected a few of the other pins that aren't used since it made
    it easier to line everything up into an RJ45 plug.

    However, when I type a letter, it appears twice. For instance, if I
    type ABC, this shows up:

    AABBCC

    At first, I thought local echo was enabled. However, I checked, and
    it's disabled.

    Any ideas why I'm seeing double?
     
  2. Don McKenzie

    Don McKenzie Guest

    has to be a software setting.
    you transmit it once, you receive it once.
    if it isn't local echo, it has to be something else in your software.
    can you hardware monitor the RX line only on a different machine?

    Don...


    --
    Don McKenzie
    E-Mail Contact Page: http://www.dontronics.com/e-mail.html

    Micro,TTL,USB to 1.5" color LCD http://www.dontronics.com/micro-lcd.html
    USB,RS232 or TTL to VGA Monitor http://www.dontronics.com/micro-vga.html
    World's smallest USB 2 TTL Conv http://www.dontronics.com/micro-usb.html
     
  3. Bart

    Bart Guest

    My software has a setting, something like "Echo Typed Characters Locally"
    with a checkbox to enable, and if enabled I get double characters like you
    describe.
    HTH
    Bart
     
  4. Rich Grise

    Rich Grise Guest

    Check for a half-duplex/full-duplex setting.

    Good Luck!
    Rich
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-