Connect with us

rs232 thermometer

Discussion in 'Electronic Basics' started by Cuprager, Dec 2, 2005.

Scroll to continue with content
  1. Cuprager

    Cuprager Guest

    http://www.cs.unibo.it/~lanconel/webtherm.html

    Has anyone made this before and got it to work?

    The reason that i am asking is that this is my first EVER attempt at
    making a circuit and guess what... it doesnt work!

    I have tested the circuit using a volt meter and i get the correct
    voltage at the chip (+5v) and all of the gnd points are, well grounded.

    What i dont know is if it is something that i have messed up or the
    software provided that is at fault! I have tried the software of a Linux
    box and have tried the windows version too... both with the same board
    and both with the same results... Err-14. Now i have checked the
    suggested fixes for this error and none of them work.

    Any help, ideas or suggestions? (other than hit it with a large hammer :eek:)

    Thanks

    Cuprager
     
  2. I haven't actually built this, but looking at the schematic for the
    hardware it should work if the software drives it correctly. While they
    are using a serial port, it doesn't actually use the TXD/RXD lines since
    the DS1621 is not an asynchronous device which makes troubleshooting
    a bit more difficult.

    Do you have access to an oscilloscope? If so, try monitoring the SCL
    and SCA lines to see if you are getting reasonable signals to the
    DS1621's. You might have to write some "disposable DOS code" to
    repeatedly drive the signals from a tight loop so you can get the scope
    to display something if you don't have access to a storage scope.

    Good luck and let us know how it turns out.
     
  3. Cuprager

    Cuprager Guest


    I know someone who has a scope, so that will be my next port of call...
    I should get to see them next week some time. Thanks for your reply!
     

  4. Yeah, but according to the webpage you mentioned Er-14 means: "Can't open
    COM-port." So I guess you have a problem on the PC-side. Is the COM-port you
    want to use known by your operating sytem? If not is it activated by the
    BIOS? If it is known, is it in use by some other program or process?
    Fiddling the hardware has no use as long as the software can't open the
    COM-port that hardware has been connected to.

    petrus bitbyter
     
  5. Cuprager

    Cuprager Guest

    Thanks for your reply petrus,

    As i mentioned in my original post, i have checked the suggested fixes
    for this error, including the COM port issue. I can open and use the COM
    port using a different application. Also, when I connect the circuit
    that i have made to the com port and run the software provided I can see
    the Voltage changing at Vin from a -12v to a +12v. I get the same
    results on two separate machines, one running XP and one running Linux.

    I have given the circuit to a friend who is going to check it for errors
    and analyse the output on a scope - like i said, i am new to this and
    this is my first circuit, so i am unsure if i have made a mistake with
    it or not! :eek:)

    Best Regards
     
  6. Cuprager

    Cuprager Guest

    UPDATE !!

    I have made the circuit work! It was, a simple error, i had not broken
    the track on the vero board under the diodes! now thats fixed it works a
    treat... thanks for your advice.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-