Connect with us

Robot servos shaking when registering to a network via radio

Discussion in 'Sensors and Actuators' started by StevenKey, Nov 20, 2014.

Scroll to continue with content
  1. StevenKey

    StevenKey

    1
    0
    Nov 20, 2014
    Hello all,after some weeks trying to develop some working code & hardware, I come here as I haven't found a solution for my problem.

    I've a robot which has a mega 2560, but the radio is an EFCom Pro V1.0.

    I tried to solve this by very different ways, and when finally solved it, it comes again, without knowing why.

    My problem is just that the two servos which are connected to the power supply I home made, are shaking when I power on the module and it registers to network.

    Seems like is powering off the servos and they come on again and again... and I don't know why nor how is doing this. (this is just a theory).

    The thing is I have the code here, and the schematic of my power supply. My servos are both SG90 TowerPro 9g. And nothing else I think is relevant.

    I say that coded a software in pure C for Freaduino Pro Mini 5V, but when I solved the problem by making very fast PWM and implementing my own software serial, I got the problem again, so I disconnected the power supply and put wired it like when solved it, and my servos were still shaking... I went very depressed, I've coded a lot of code with this project, and I don't mind because I love it, but really, I think I've made a lot of work on this. So, please, what can be making my servos to shake like being under electroshock, when I power on the module and Call Ready is received? I only issue checking commands as AT+CREG? and AT+CGATT, and when both ready or okay, then I enter into a loop of simple AT commands. And the servos stop shaking the whole time, then after some seconds of running, they start to shake a bit, like if the signal goes down and the TX power is higher...

    really, I don't know which problem is with my power supply, but I tried to power on the servo with an external battery and the same.

    Both servos are new. I just received the second 2 days ago, and tested yesterday night with same results...
     
  2. davenn

    davenn Moderator

    13,581
    1,868
    Sep 5, 2009
    hi there Steven

    Welcome to Electronics Point :)

    I cannot help you with your specific problem ... just wanted to greet and welcome you

    We have several guys on the forum that quite knowledgeable with micros

    Dave
     
  3. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,384
    2,771
    Jan 21, 2010
    What happens if you disconnect the servo from the microcontroller?
     
  4. Arouse1973

    Arouse1973 Adam

    5,164
    1,080
    Dec 18, 2013
    What power supply are you using and where do you take the power for the servos from, what servos are you using? Can you show us a schematic? What timings are you using for the servo PWM.
    Adam
     
  5. Frenoy Osburn

    Frenoy Osburn

    64
    24
    Nov 20, 2014
    Apart from what Adam mentioned, could you also tell us how are you controlling the PWM output? Does the servo still "oscillate" when you give a fixed PWM value?

    If you happen to have access to an oscilloscope, I would probe this signal and verify the same to rule out any issues with the PWM module you have going.
     
  6. BobK

    BobK

    7,682
    1,685
    Jan 5, 2010
    It sounds to me like the PWM signal is not continuing while you are doing the communication.

    Bob
     
    Gryd3 likes this.
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-