Connect with us

Repairing Betamax VCR

Discussion in 'Troubleshooting and Repair' started by Jdlca, May 17, 2016.

Scroll to continue with content
  1. Jdlca

    Jdlca

    2
    0
    May 17, 2016
    Hey all, new to the forum and very new to electronics repair, but I like to get deeper into it! I have some questions and hoping someone can point me in the right direction.

    I bought a Sanyo Betamax (Betacord according to Sanyo) VCR that I bought off ebay, broken, as a project to fix. I finally got it today and dove nose deep into it, so when plugged in the clock flashes like it should, but when the power button is depressed nothing happens, no light, no clicks, no nothing, when pushing all the buttons, nothing happens, the only thing is when you push the timer button, so the unit will record on timer, the light comes on and the channel selector buttons light up when depressed, but still no power light when depressed.

    My best guess was something was up with the power supply, since I would think it's highly unlikely that all the motors and everything was just dead. I noticed the power supply had some capacitors that looked like they had leaked but after closer look it's adhesive but it made a giant mess and had touched some connectors and I'm thinking as it aged, it caused a short. There is also an area that looks like it had gotten really hot at one point, I removed the power supply and removed some capacitors and found one with a bulge and leak at the bottom. I ordered some new capacitors because I figure I might as well replace them all.. There are some other components I'd like to replace, but I don't know what they're called or how to know what the specs on it are.. I feel certain that this power supply is the issue, does it sound like an issue that a bad or possibly few bad capacitors could cause or is there more to the situation here? Including some pics.. Thanks all! :)

    [​IMG]
    [​IMG]
    [​IMG]
     
    Last edited: May 17, 2016
  2. 73's de Edd

    73's de Edd

    2,920
    1,235
    Aug 21, 2015
    .


    Sir Jdlca . . . . . . .

    Your mystery part is a transformer / inductor . . .VERY HIGH_HIGH probability of normally having no problem whatsoever..
    The found family of adhesive you have encountered is less problematic than yellowish brown formulations. With their high proclivity of leakage in HV areas or overall exhibition of hygyroscopic tendencies in high impedance circuitry areas.

    Can't delve into any more without a SANNNNNN-YOOOOOOOO model number .
    Any mechanics, belts, clutches and drives bordering on non obtanium status.


    73's de Edd




    .
     
  3. shrtrnd

    shrtrnd

    3,763
    485
    Jan 15, 2010
    Yep. 73's de Edd's advice. Find a schematic on it and hope it's not a part that is no longer made.
     
  4. Jdlca

    Jdlca

    2
    0
    May 17, 2016
    Thanks for the replies guys, I appreciate all the info from 73 de edd, my mistake, I should have entered the model number; it's a Sanyo Betacord 4500.. As for the mechanical parts, belts are a for sure as all three are dry rotted and need replacing but everything else is in working order mechanically, there just isn't any power getting to anything, only to the clock and timer button, having found a bad capacitor in the power supply, I'm hoping when it's changed it'll do something, show some sign of life. man I wish Sanyo still made parts, could just order a power supply! Wish it was that easy!
     
  5. 73's de Edd

    73's de Edd

    2,920
    1,235
    Aug 21, 2015
    .



    Sir Jdlca . . . . . . .


    Your 2nd and 3rd photos down are showing a portion of the linear power supply that the unit uses.
    I found a SANYO manual for this unit, BUT it is having NO schematics , but a very- very THOROUGH coverage of its mechanics and adjustments.(RARELY needed ! )
    Can you get more photos of the REST of that power supply section ?

    Also get the Ohh-FISH-ull model number from the rear of the unit , it should have a prefix before the 4500



    73's de Edd




    .






     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-