Connect with us

Repair help on LG OS 5020C oscilloscope

Discussion in 'Troubleshooting and Repair' started by Jexta, Nov 29, 2015.

Scroll to continue with content
  1. Jexta

    Jexta

    4
    0
    Nov 29, 2015
    I have a problem with a LG OS 5020C oscilloscope, its the same as LG OS 5020 but with component tester.
    You can find some block diagram on page 56 in the manual:
    http://www.testequipmentdepot.com/ezdigital/pdf/os5020-5020c_manu.pdf

    All I can tell is that suddenly the intensity, the vertical adjustment and the channels didnt work anymore.
    I really cant remember what I did before its failure, it worked fine, I tested some quartz oscillators and some batteries. Suddenly it didnt work anymore.
    I googled and found two posting of people who got exactly the same problem:
    https://www.electronicspoint.com/threads/connected-my-oscilloscope-up-backwards.268276/
    http://charliexray.blogspot.de/2010/07/osciloscopio-goldstar-os-9020p.html

    The second link is from a Spanish guy who has a slightly different oscilloscope, but its from the same manufacturer and the voltages he measured on the mainboard are exactly the same like the voltages I measured.
    There are some checkpoints on the mainboard where the voltages are printed on the board, this is what I measured on these points:
    checkpoint (measured value)
    140V (12V)
    212V (270V)
    56V (22V)
    12V (12V)
    -12V (-12V)
    5V (5V)

    I dont really understand how he did repair his oscilloscope or what the problem was, it seems that he inserted some resistor into the power supply to correct the voltages.

    Well, my power supply looks ok, nothing seems to be damaged. I also own a LG OS 5020 oscilloscope, the version without component tester. The power supply and the transformer are exactly the same (same IDs printed on them), so I opened it and switched the power supply and also the transformer with the ones from the faulty oscilloscope. It worked fine and the measured voltages were like they should be. So I think it cant be the power supply or the transformer which is faulty. The error must come from the mainboard.

    So I measured the voltages on many soldering joints and put the values into a graphic, this is what it looks like:
    (see reply post)

    I also made a graphic for the power supply so you can see what's going on there:
    (see reply post)

    The bigger colored values are the ones which I measured with a multimeter against ground. The white values are the ones which I measured on the working oscilloscope against ground. The mainboards of the two oscilloscopes are nearly the same, the layout slightly differs but the printed values/descriptions are the same.

    I dont really understand all those values, the thing I wonder most about is that "140 V RTN" pin on the power supply. Does it mean "return voltage"? And why is that voltage negative? I measured -56V on "+140 VRTN" pin of the working oscilloscope.

    The power transistor on the left is mounted onto the chassis for cooling, it's not as hot as the one in the working oscilloscope, probably not much current flowing there.
    Datasheet of the power transistor:
    http://datasheet.eeworld.com.cn/pdf/JMNIC/276567_2SA1668.pdf

    So my problem now is that I dont know where to look for the source of all those wrong values. I dont know which path to trace. Where does it start? It seems like a loop to me. It also looks like the DC voltage from the mainboard seems to influence the AC voltage of the power supply.

    Any help is appreciated, I believe it's possible to repair that thing somehow :)
     
    Last edited: Nov 29, 2015
  2. Jexta

    Jexta

    4
    0
    Nov 29, 2015

    Attached Files:

  3. Jexta

    Jexta

    4
    0
    Nov 29, 2015
    I think I found the problem: resistor R350 is damaged and has to be replaced! It's a grey 2.2 ohms resistor right beside the power supply pins on the mainboard, it's color code is red-red-gold-gold-silver.
     

    Attached Files:

  4. GPG

    GPG

    452
    66
    Sep 18, 2015
    With the grey body, it could be a fusible resistor. Check the value on the good unit.
    Back bias. Here's one method
    http://www.aikenamps.com/index.php/what-is-back-biasing
     
  5. Jexta

    Jexta

    4
    0
    Nov 29, 2015
    Thank you for the reply.You're right! I just googled again and found a document with the parts list of this oscilloscope. It's a 2.2ohms 1/2W fusible resistor. I've never heard about such resistors before. They're hard to find, but I found some on ebay.
    The oscilloscope is working again with a standard 2.2 ohms resistor, I will replace it with a fusible resistor then.
     
    Last edited: Dec 8, 2015
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-