Connect with us

Remote Fan Controller (IR)

Discussion in 'Electronic Repair' started by Peter K, Oct 12, 2007.

Scroll to continue with content
  1. Peter K

    Peter K Guest

    Hi Guys.

    I have a customer who has 3 Infrared Remote Ceiling Fan Controllers (No Name
    Brand).
    The Receiver has Live and Neutral in, Fan Live Out, Light Live Out, and
    Neutral Out.
    She actually has about 6 of these installed in her house, and all work fine
    except for these two.

    The Controls have a High, Medium, Low and Off Fan Button, and a Light Button
    that cycles between off and 5 levels of brightness.

    The 3 have the problem as follows:
    Light Brightness works fine, until you switch the fan on.
    once you switch the fan on, it operates at the speed you selected,
    but then the receiver stops responding [the piezo buzzer in the receiver
    does not even beep to indicate that
    it received a valid button press.] , and just holds the same state
    (Brightness and Fan Speed).

    The only way to get the receiver responding again, is to remove the power,
    and reapply it after about 20s.

    I have tried the receivers at another location (at my offices), with a
    different fan, and have tried several remotes, and IR sensors,
    all with the same result.

    Anybody had any experience on these [with the problem]?

    P
     
  2. Jerry G.

    Jerry G. Guest

    The reciever most likely has failed parts. This is not something you
    will be able to service yourself unless you can have a means and the
    skills to troubleshoot it. I am sure that the manufacture does not
    support service for this type of unit because of the service cost. If
    you can find out the manufacture of the particuler receiver you have,
    you may be able to buy a new replacement, if the cost is feasible. If
    you contact the dealer where the fans were bought, they may be able to
    give you a contact for spare parts.


    Jerry G.
    ======
     
  3. I wonder whether the fan is generating enough noise to crash the
    microcontroller? Perhaps a suppressor has gone, or the power supply drops
    out enough to crash it when the fan's running? I'd look at the supply rails
    on a scope to see what happens.

    Just a thought...

    Theo
     
  4. Peter K

    Peter K Guest

    Hi Theo

    I thought about the Fan generating too much noise, but I get the exact same
    result with just the light connected. (Removed the Live to the Motor).

    So it seems to be something else.
    I have checked the 3 main caps with a normal ohm meter, and they seem to be
    ok (with the value increasing up to a point, reverse the polarity of the
    test leads, and the value again increases to the same point).

    I do not have an ESR meter though,
    so if somebody thinks it is the caps, then I will go and sub them.

    The unit costs about R280.00, ($37US), and in South Africa, it is a lot for
    a Pensioner just to fork out to replace the unit.

    P
     
  5. Peter K

    Peter K Guest

    Ok, Step further now.
    With both the fan and light disconnected (but power applied), checked with a
    DC Voltmeter the voltage going to the IR receiver (and the single chip on
    the controller board). Getting a nice stable 6 volts.

    But when i press a button to turn the fan on, the voltage drops to about 3
    volts (within 2 seconds).
    During the time that the voltage is dropping, the receiver still responds.
    but after that 2 sec time, it no longer responds.

    There is 1 transistor that runs the light circuit, and 3 transistors for the
    fan circuit. Pulling the 3 fan transistors, and then trying, the voltage
    does not drop, and the receiver keeps on responding.

    Looks to me like the trannies are drawing to much power, and loading down
    the low voltage.

    The circuit does not have any transformer, so it looks like it has another
    way of reducing the mains voltage down to the 6v.

    I have replaced all the caps I had stock of, and all the resistors check
    within range.
    Can anybody venture at a guess of whether there is a problem in the tranny
    stage, or in the power reducer (not being able to supply current under the
    load of the chip driving the trannies)

    Thanks
    P


     
  6. James Sweet

    James Sweet Guest


    The power supply is probably a mylar capacitor and a zener diode. Try
    changing that capacitor, if it's bad, the psu cannot supply enough current.
     
  7. Peter K

    Peter K Guest

    Hi All.
    Here is a controller that is highly similar to the one that I am talking
    about :
    http://cgi.ebay.com/harbor-breeze-c...ameZWDVWQQrdZ1QQcmdZViewItem#ebayphotohosting

    BTW James,
    If I substitute the cap, do I have to use a mylar (during the test), or will
    any cap with the same voltage and cap rating work?
    I have not seen a Zener on the board (though the places that are marked for
    Zeners have resistor-like components in them - do they do zeners that look
    like resistors?)

    I have tried googling the powersupply as you have suggested it is, but
    cannot find any more info on it. Does anybody have a proper name for it ?

    Peter
     
  8. Peter K

    Peter K Guest

    Looks like the Cap (0.6uF I think) and the 48v Zener are in parallel.
    Am I looking at the right part of the cct?

    Also, if it is the right part, how does the voltage get down to 6v for the
    IR Detector and Chip?

    P
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-