Connect with us

Remote control not powering on! Help me please!

Discussion in 'Troubleshooting and Repair' started by DroneFisherMan, Sep 19, 2018.

  1. DroneFisherMan

    DroneFisherMan

    2
    0
    Sep 19, 2018
    Hi All,

    i am using bayangtoys X16 GPS drone.
    I managed to solder the "alfa APA-M04 7 dBi gain RP-SMA directional panel antenna Wi-Fi" on the board, and it was working absolutely fine. Until, I put hot glue on the antenna's solder to make it more solid.

    Since then , when I power on the remote the red light comes on for a second and beeps then it goes off. I removed the hot glue and still its doing same thing..

    Have I burnt the Tx?

    I have checked for any short on the antenna's ground and main wire, there is no short there. I have checked the battery and power, and all looks good.

    Could anyone help me out please!

     

    Attached Files:

  2. DroneFisherMan

    DroneFisherMan

    2
    0
    Sep 19, 2018
    the power does come up but then goes away, if I immediately power it off and power back on, then there is no LED,

    However, if I pause for 5-10 seconds the intensity of LED is high, and subsequently low if powered on during less intervals.
     
  3. bigkim100

    bigkim100

    56
    0
    Apr 17, 2013
    I would suggest that you may have cooked the Bayang toys transmitter. Remove the added cicuit , and see if it works then...if not , you have cooked it. You would probibly do better using a cheap wireless wi-fi repeater.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-