Connect with us

Rega Mira 1 Integrated Amplifier LED's not functioning

Discussion in 'Troubleshooting and Repair' started by Chaggy78, Apr 6, 2013.

  1. Chaggy78

    Chaggy78

    35
    0
    Dec 30, 2012
    Hi all!

    Thanks for looking at this thread.
    I have recently purchased a Rega Mira 1 Integrated amplifier, it works perfectly except that the LED on the volume dial and selector dial and also the power led are not functioning.
    Does anybody know whether this may be repairable and if so how t do it.
    I was thinking that the LED's may have burn't out over time but not too sure, also i was wondering that there may be components going faulty that supply power to the LED's?
    I have not opened up the amp yet until i get an idea of what may be wrong.
    Any help or advice would be ace!
    I want to repair it myself if possible but if not i guess it's off to the repair shop which could be expensive!
    Many thanks!
     
  2. Harald Kapp

    Harald Kapp Moderator Moderator

    9,219
    1,857
    Nov 17, 2011
    LEDs do fail very rarely. More probably a wire is broken, a resistor burnt or a driver transistor defect.
    You will not be able to tell unless you open the amplifier and look at the relevant parts. Measure the voltage across the LEDs. If the voltage is high enough for the LED (e.g. ~1.6V for a red LED), then the LED really is defect. If there is insufficient voltage, the failure is elsewhere. You'll have to pinpoint the failure by following the signal chain.
     
  3. Chaggy78

    Chaggy78

    35
    0
    Dec 30, 2012
    Thanks very much for your reply i really appreciate that.I will open up the amp soon and measure the voltage across the LEDs and get back to you.
     
  4. Chaggy78

    Chaggy78

    35
    0
    Dec 30, 2012
    HI again,
    Just to follow up on the previous post that I opened up the amplifier and could not test the voltage across the LED's as they are hard to get to and I don't feel confident i can do it myself. I think i'll have to have it looked at by the repair shop at some point. Thanks for all the help.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-