Connect with us

Rascal house alarm

Discussion in 'General Electronics Discussion' started by neil, Jan 20, 2012.

Scroll to continue with content
  1. neil

    neil

    2
    0
    Jan 20, 2012
    Hi
    I have a Rascal alarm which has been installed for about 10 years and has worked without any problems. Yesterday I had cause to switch electricity off and switched it back on about an hour later. When I tried to put the alarm on last night I noticed that non of the lights on the key pad box were illuminated and I was unable to enter my alarn code. Do you think that the internal battery has gone?
    Thanks
     
  2. Resqueline

    Resqueline

    2,848
    2
    Jul 31, 2009
    If it hasn't been changed in 10 years it's certainly "a goner". Five years is the normal replacement interval.
    Here's a recent thread on this forum about a similar alarm by the way.
    There may be a T1A 20x5mm fuse in connection with the battery. Better check that too while you're in there.
    I don't know if replacing the battery will fix your problem though.
     
  3. neil

    neil

    2
    0
    Jan 20, 2012
    Thanks alot. I have replaced the bateery and everything is fine
     
  4. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,411
    2,779
    Jan 21, 2010
    Place a note somewhere visible that reads "Replace battery in 2017"
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-