Connect with us

Rabbit Core Module: programming issue

Discussion in 'Electronic Design' started by Marco Trapanese, May 31, 2007.

Scroll to continue with content
  1. Hi!

    Before posting I read a lot of message several forums.
    I run the Dynamic C 10.11 with a Rabbit Core Module RCM4100. I have
    programmed several times the module on my own board composed of a 3V3
    power supply, a LED connected to PE1 and nothing else. The /reset in is
    unconnected as it is tied-up on the module itself.

    I wrote a simple program to flash the led and it works fine. After
    several programming cycles I can't connect to the processor anymore. The
    IDE returns error while is sending Cold Loader.

    If I remove the programming cable the led flashes as expected, so the
    module is running. Furthermore:

    + both primary and RTC clock are running
    + power supply is ok
    + checked the PROG connector rather DIAG
    + checked the right COM port on laptop
    + the lapton has a native COM port, I don't use an USB serial converter
    + turned off, turned on after 1h: same error

    If I move the module from my board to the Rabbit DevBoard I can program
    it. Thus, I guess there is a problem with my board... But why I was able
    to program before?

    What should I check?

    Thanks
    Marco / iw2nzm
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-