Connect with us

PS4 lag...tried every fix I could find...PLEASE HELP!!

Discussion in 'General Electronics Discussion' started by Victoria Parish, Apr 5, 2016.

Scroll to continue with content
  1. Victoria Parish

    Victoria Parish

    18
    1
    Apr 5, 2016
    I live in the country and basically the most decent internet provided to us is WildBlue. Our modem is on the opposite side of the house as my ps4 and no internet runs in any of the rooms except for where they are currently at. Just want to point out first that there isn't a chance of me moving the ps4 into the room with the modem or moving the modem to any other rooms in the house.
    I wanted to play online games so badly that I bought a Belkin wifi router.. the signal in my house was so poor I couldn't get into games, or stay in them for that matter...and if I could, there was nothing but myself fighting walls instead of actual people.
    So I took it back and bought the "newer" $200.00 Netgear Nighthawk R7000 model version with high speeds and range.
    It boosted my signal plenty throughout the house but still, not enough to play online. Frustrated, I went and bought a wifi range extender thanks to some COD buddies of mine and their "quick fix" advice.
    Helped boost speeds a bit, but still.... not enough to play.

    Download connection speeds went from about 15.3 kbps and upload from 53.7 kbps to about 2mbps down and 100kbps up.

    So I caved and bought an Ethernet cord, drilled holes in the house and ran it directly from the new router to my ps4. Hardwired, Boom. I thought that was the ultimate fix.
    Speeds went up a bunch. Down is now around 6.9-7.3mbps and up is around 335kbps.
    Not amazing, but much better than before.. should definitely be enough to play online...but NO!!!! Nothing has changed.

    I have a lag on Call of Duty Black Ops 3 that puts me at about 2-3 seconds behind in online gaming. That's Mississippi seconds. That also goes for all aspects of the game, shooting...reloading, moving, etc. Sometimes I get the fun stuff where I basically just run directly into walls for a few minutes total of a game and saves me the trouble of even attempting to get kills.

    So I googled......and googled.
    Next steps I took.... I created a static ip address and set it to my router and ps4, didn't fix it.
    Set the ps4 in DMZ, didn't fix it.
    Made sure UPnP was enabled. No fix.
    Used the MAC address from my ps4 and created a high priority traffic setting in my router under the QoS. NO CHANGE.

    I don't honestly know anything about systems, or internet in genereal. Everything I've done has been from tutorials, google, you get the point. But I am still seconds behind in games, or can barely find them in general.

    Yes, I have a few devices hooked up to the same router... That is something that can't be changed. But I have 30Gigs of high speed a month. Just upgraded to that package recently and pay a stupid amount for it too, all in the sake of trying to play online.
    It's not the ps4 itself because I have played online on a wifi connection at a friends house with the same ps4 and had no issues whatsoever....
    I've also tried just running wifi and that has done me no good...same connection.

    I have noticed on the side of my name during play, while everyone has either yellow or green signal bars...I assume is the PING? I have just one little red one or nothing there at all. Not sure if that has anything to do with it, but please.... someone help me figure out what to do...​
     
  2. Gryd3

    Gryd3

    4,098
    875
    Jun 25, 2014
    When it comes to online game-play, there is less to do with Up/Down speeds and more about 'latency' or 'ping' .
    Something else incredibly damaging it 'packet loss'.

    Games typically use 'UDP' to transmit information to/from game servers during play. This is an incredibly fast method or transport, but it has not acknowledgements. If you send out 10 packets and none of them arrive, you don't get told about it!

    'Lag' is often caused by poor latency/ping times.
    'Jitter' / Jumpy motion and random drops is caused by excessive 'packet loss'.
    Both of these problems could be caused by 'horrible' Up/Down speeds... but the required speeds are really low to be honest.

    So! Please leave things the way they are, and hop on a computer in the home. I'm assuming you run windows, so I will list the steps I want you to perform based on windows commands.
    - Open Command Prompt. (Search for 'cmd' in the start menu... or press WindowsKey+R and type cmd in the box)
    - Type 'ipconfig' in the Command Prompt, hit enter and look for 'Default Gateway' . (This address is usually 192.168.x.y .. where x is usually 0 or 1, and y is usually 1 or 254 . If it's different, don't worry. This is the IP address of your router.. if you know this... skip the ipconfig step, and continue to ping.)
    - Type 'ping <gateway>' (Please replace <gateway> with the address in the last step.)
    - After you ping the gateway to make sure the problem is not *in* your home. Start pinging other things. You can ping 'google.ca' and 8.8.8.8 , please share results for those as well.
    - Please also turn on the PS4 and ping the static IP address you assigned it to make sure the PS4 is not at fault. I know you used it else-where, but assuming it's good without testing is never a good idea ;)
    ** This ping tool is very important when troubleshooting! . Windows sends out 4 packets by default... harder test can be run later if needed. We are very interested in making sure no packets are lost, and that the times are very low. They should be far less than 20ms for min, max, and average. Please share all of your ping times!
     
    Victoria Parish and Anon_LG like this.
  3. Victoria Parish

    Victoria Parish

    18
    1
    Apr 5, 2016
    First of all, I appreciate your help!
    Here's the pins I got for each you asked me to ping.

    All 4 pings were received from the default gateway with 0% loss.
    Approx. round trip in milli-seconds:
    Minimum=1ms, Maximum=1ms, Average=1ms.

    All 4 pings were received from ps4's static ip address with 0% loss.
    Approx. round trip in milli-seconds:
    Minimum=1ms, Maximum=4ms, Average=2ms.

    All 4 pings were received from google.ca with 0% loss.
    Pinging google.ca [216.58.217.35] with 32 bytes of data:
    bytes=32, time=578ms, TTL=54
    bytes=32, time=576ms, TTL=54
    bytes=32, time=615ms, TTL=54
    bytes=32, time=591ms, TTL=54
    Approx. round trip in milli-seconds:
    Minimum=576ms, Maximum=615ms, Average=590ms.

    All 4 pings were received from 8.8.8.8 with0% loss.
    Pinging 8.8.8.8 with 32 bytes of data:
    bytes=32, time=651ms, TTL=54
    bytes=32, time=585ms, TTL=54
    bytes=32, time=581ms, TTL=54
    bytes=32, time=594ms, TTL=54
    Approx. round trip in milli-seconds:
    Minimum=581ms, Maximum=651ms, Average=602ms.

    I hoped I typed all of that correctly for you, and you can decipher all of that the ways I cannot. lol
     
  4. Arouse1973

    Arouse1973 Adam

    5,165
    1,087
    Dec 18, 2013
    Hello Victoria. Can you tell us what your NAT type is, with DMZ enabled it should be NAT type 1. Also does this happen in all game modes? Have you tried setting up a private match with one of your friends if you can. I used to play COD all the time but BO3 is the only one I haven't played yet so don't know much about the game modes.
    Thanks
    Adam
     
    Victoria Parish likes this.
  5. Victoria Parish

    Victoria Parish

    18
    1
    Apr 5, 2016
    My Nat Type is set at 2(Open). It was set to Strict somehow until I tried port forwarding last night using the website and codes specifically for ps4. Since I opened those ports I've had Nat 2. Yes, it does happen in all game modes, however I haven't attempted a private match simply because I get kicked for connection problems while in games with friends. It never occurred to me to try a private match instead of just pvp.
     
  6. Arouse1973

    Arouse1973 Adam

    5,165
    1,087
    Dec 18, 2013
    I just pinged the same address and here are my results. I have quite fast broadband so not sure what your ping rate should be from where you are. But it does seem quite a long time, over half a second.

    PING.PNG
     
    Victoria Parish likes this.
  7. Victoria Parish

    Victoria Parish

    18
    1
    Apr 5, 2016
    That just leaves me with the beautiful question of, do you know any ways to fix it? lol
     
  8. Gryd3

    Gryd3

    4,098
    875
    Jun 25, 2014
    The times to google are HORRIBLE :(
    It's taking half a second to get to google and back. You *should* be able to get to china and back in half that time...
    I'm certain this is a problem with your internet provider...
    Can you please also run a 'tracert google.ca' in Command Prompt and share the results?
    (Please edit out the IP address of the 2nd or 3rd line... This would be your 'public ip' address immediately after the 192.168.x.y address )
     
    Victoria Parish likes this.
  9. Arouse1973

    Arouse1973 Adam

    5,165
    1,087
    Dec 18, 2013
    Give it a go. I used to get loads of lag playing some of the older games. Then found out the hosts was lag switching, but it can't of been that all the time. When you see the kill cam and you didn't even fire a shot, knowing full well you emptied a whole mag into the player, frustrating to say the least.
    Adam
     
    Victoria Parish likes this.
  10. Arouse1973

    Arouse1973 Adam

    5,165
    1,087
    Dec 18, 2013
    Not Yet :)
     
  11. Arouse1973

    Arouse1973 Adam

    5,165
    1,087
    Dec 18, 2013
    Ok in the UK if you experience slow connection speeds for a certain length of time they cut your bandwidth to ensure the data gets through. They keep doing this until it's stable. Now if you had slow speeds before you upgraded all your kit they may have throttled your speed back. It may be worth asking them to reset you bandwidth. I know people over here have had to do that before and then they had full speed again.
    Adam
     
    Victoria Parish likes this.
  12. Victoria Parish

    Victoria Parish

    18
    1
    Apr 5, 2016
    C:\Users\Pawn USA>tracert google.ca

    Tracing route to google.ca [216.58.217.3]
    over a maximum of 30 hops:

    1 1 ms 1 ms 1 ms (ip address)
    2 * * * Request timed out.
    3 * * * Request timed out.
    4 * * * Request timed out.
    5 * * * Request timed out.
    6 582 ms 609 ms 608 ms (address?)
    7 * * * Request timed out.
    8 842 ms 636 ms 627 ms 67.134.166.226
    9 608 ms 566 ms 598 ms 72.14.234.59
    10 724 ms 596 ms 600 ms 209.85.250.237
    11 585 ms 606 ms 591 ms den03s09-in-f3.1e100.net [216.58.217.3]

    Trace complete.

    was that right?
    I'm assuming those aren't good....
     
  13. Victoria Parish

    Victoria Parish

    18
    1
    Apr 5, 2016
    Frustrating is definitely understating the feelings I get while emptying a clip into someone's back, just so they can turn around and punch me... lol
    I am generally going game with end scores of like 0 or 3 max-25 or more deaths. That's beyond ridiculous to me. Gives me harmful thoughts to my console. :(
     
    Arouse1973 likes this.
  14. Gryd3

    Gryd3

    4,098
    875
    Jun 25, 2014
    Thank you very much.
    The IP address for 1, should be your 'private' IP and is safe to share as long as it is one of the following:
    192.168.x.y
    172.[16-31].x.y
    10.x.y.z

    If you do a quick google search for 'my ip', it should tell you your public IP address which is often jump 2 or 3. If your public IP address reported by google is different than jump 6, can you please share it?
    Jump #6 should be an address from your Internet Provider, or from one of their providers...
    The fact that the time on jump 6 is so high is alarming. Can you please ping the address from jump 6 and see if you get similar times?
    This is beginning to feel a lot like your internet provider providing shoddy service...
     
  15. Victoria Parish

    Victoria Parish

    18
    1
    Apr 5, 2016
    For Jump #6 I got as follows..

    Pinging with 32 bytes of data:
    All 4 received with 0% loss.
    bytes=32, time=612ms, TTL=59
    bytes=32, time=625ms, TTL=59
    bytes=32, time=631ms, TTL=59
    bytes=32, time=629ms, TTL=59
    Approx. round trip in milli-seconds:
    Minimum=612ms, Maximum=631ms, Average=624ms.
     
  16. Arouse1973

    Arouse1973 Adam

    5,165
    1,087
    Dec 18, 2013
    Do you have the Exede package? It states you can get 12 Mbps, that should be enough for gaming with minimal lag.
    http://www.wildblue.com/
    Adam
     
  17. Gryd3

    Gryd3

    4,098
    875
    Jun 25, 2014
    Is the number 6 jump address different from the result here?
    https://www.google.ca/search?q=myip
     
  18. Gryd3

    Gryd3

    4,098
    875
    Jun 25, 2014
    You know what... I just looked up the ISP, you are using a satellite dish? (Is it pointed to the sky, or the horizon?)
     
  19. Victoria Parish

    Victoria Parish

    18
    1
    Apr 5, 2016
    The internet was "fixed" yesterday.
    We were only getting 10 gigs a month, so upped it to 30. They reset everything right there and said we'd be running at high speed until the 16th because that's the end of our monthly cycle then it would restart.

    So, from the way it's looking.... there's nothing I can do myself?
    If not, if I could get ahold of them, which would most likely be at some point this week, what should I ask them to do, or fix?
    I'm clueless as far as talking to someone on the phone and dealing with this sort of thing goes.

    Also, a continuous thankyou for all of the help!
     
  20. Victoria Parish

    Victoria Parish

    18
    1
    Apr 5, 2016
    Yes, the address that I did the test on was different to the one in your google link. I'll run a new one with the numbers from that site and post those. :/
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-