Connect with us

protel 99 SE won't Unlock?

Discussion in 'CAD' started by Fred, Nov 20, 2006.

  1. Fred

    Fred Guest

    Hi All,

    I am a licensed user of Protel 99 SE and have used it for a few years on
    several computers. Recently, I bought a new computer and tried to load
    my software on the machine. It will load but will not allow me to unlock
    the software. I know I,m doing it right, and the user codes are right
    I've had the software for several years.

    To make sure my computer wasn't faulty, I tried to load the software on
    a second Win XP machine in the lab. I had the same problem.

    I believe the SW disk has been damaged and no longer loads properly.
    Perhaps having Trend Micro Antivirus and Webroot spyware Sweep is just
    too much. Has anyone had this problem? Can I get or download a
    replacement copy? Can't seem to find any help from ALtium.

    Thanks,


    Fred



    Regards,

    Fred Sprague
    PMR, Inc
    607 West Broadway Ave
    Faifield Iowa 52556
    (641)469-5507


    ..
     
  2. Have you remembered to put the 'dashes' in the code?
     
  3. Fred

    Fred Guest

    Hi Martin,

    When you enter the codes the dashes are automatically entered. It's
    interesting as some of the tools open, others won't. I'm disabling my
    spyware and virus protection to see if that helps.

    Thanks for the reply,

    Fred
     
  4. Guest

    I've only ever tried the demo, but it licensed by writing to the disk
    in an obscure way. Perhaps you're running NTFS on the latest disk
    instead of FAT32?

    colin
     
  5. Fred

    Fred Guest

    Hi Colin,

    A very good point. I reinstalled the software on a computer in the lab
    using Fat32 for C: disk. It worked, my software disk is OK. Then I went
    and looked at the laptop computer on which this software will not
    unlock. It's FAT32 formatted. Maybe worth reformatting the disk an
    option if I can find the restore disk.

    Thanks,

    Fred
     
  6. Fred

    Fred Guest

    Fred Again:
    So I've reinstalled the software on the problematic laptop. I can
    un-lock all the modules except "Schematic 5.0" (a pretty necessary
    part). When I try to unlock Schematic5.0, the following message error
    message appears:

    Exception EAccess Violation in module AdvSch.dll. Access violation @
    address 01851212 in module 'AdvSch.dll' read of address 00000000.

    Look familiar?

    Regards,
     
  7. Fred,
    While this particular problem is not familiar, there is an overall
    familiarity to your current plight. Are you knowledgable of the
    "full-clean-uninstall" procedure for P99SE? The current state that you find
    yourself in sounds like it could, just possibly, be related to some DLLs
    that the normal uninstall does not remove.

    Here is copy of the clean uninstall procedure.
    (In Step 5. The *.BPL or *.DPL files number approx. 5 of each. You are
    looking for CSRTL50.bpl, ProtelComponents50.bpl, vcl50.bpl, vcldb50.bpl,
    vclx50.bpl, CSRTL.dpl, ProtelComponents.dpl, vcl30.dpl, VCLDB30.DPL, and
    VCLX30.DPL. Usually, some are removed by the uninstall but not all.)


    Version # Protel 99SE/ Service Pack 6:

    PROBLEM: Is there a specific uninstall procedure for Protel? I have
    uninstalled and reinstalled using add and/remove programs but Protel is
    still acting up.

    SOLUTION:

    1) Un-install Service Pack 6 for 99SE
    2) Un-install 99SE
    3) Delete the Design Explorer 99 SE directory
    (make sure you have no personal files or libraries stored here before you do
    this).
    4) Delete the files *99SE.* from your Windows or Winnt folder
    5) Also delete from the Windows or Winnt folder *.bpl and *.dpl, if they are
    still remaining.
    6) Re-install Protel 99 SE
    a) If Win 9x then Reboot
    7) Re-apply Service Pack 6
    a) If Win 9x Then Reboot
     
  8. Fred

    Fred Guest

    Hi Brad,

    Thanks for the post. I did as you suggest but was unsuccessful. Perhaps
    files are in other directories on Win-XP. I deleted directory "Design
    Explorer 99 SE". I deleted *99se.* in C:\windows. Then I did a search
    for *.bpl, *.dpl and found them in windows\system32. SO I deleted them
    as well. Then the computer was rebooted and I installed 99se. When I
    tried to unlock the software elements I got the same reaction; could
    unlock all but Schematic.

    I'm bummed.

    Fred
     
  9. Zilog

    Zilog Guest

    And then software companies are surprised that people, honest users,
    revert to the cracked market to be sure their software, payed software
    btw, will run for years to come.
    I'me not in favor of cracked sw but I like to have full service for at
    least 10 years. FULL service.
    I still run software from mid 90's. It is still able to do the job very
    well. And then I know this software.
    Zilog
     
  10. Hi Brad,
    Fred,

    If your personal situation has not prevented you from doing so, have you
    tried reformatting the hard disk within the PC that you are having problems
    with?

    Doing that won't necessarily solve your problem (as there could be some
    aspect of the hard disk which is stopping the schematic server from
    unlocking, and which even a reformat might not fix), but if it is feasible
    for you to do that, it might still make a difference.

    I am fully aware that doing that would not be a trivial undertaking though,
    so something else which would be worthwhile for you to experiment with
    beforehand is generally "experimenting" with the Client99SE.ini file
    contained within the Windows (/ WINNT / whatever) directory. Before you do
    anything else, make a backup copy of that file (and store that copy in some
    other folder), and then see what happens in various circumstances, such as
    totally deleting the file contained within the Windows directory (is it
    subsequently regenerated when you next start Protel 99 SE?), examining the
    details listed under the [Locks] section (probably located at the very end
    of that file, but search for it if it's not) and perhaps even editing the
    details which are listed there (and especially paying attention to the line
    which specifies the lock for the "Sch" server).

    And another file in the same (Windows) directory which could also be worth
    similarly experimenting with (after once again making a backup copy of that
    file within another folder) is the AdvSch99SE.ini file (given that you have
    been experiencing problems with the schematic server).

    If you eventually do manage the unlock the schematic server again after
    experimenting with those files (and perhaps yet other Protel 99 SE related
    files also located within the same (Windows) directory), it is not out of
    the question that you would then need to "recustomise" your copy of Protel
    99 SE again, but that would still be a small price to pay to regain full
    functionality again.

    And as far as Altium's attitude is concerned, it's one thing for them to no
    longer provide support in the form of answering any questions about how to
    actually use Protel 99 SE, but it's quite another to provide no assistance
    to anyone who is experiencing problems with unlocking any of the servers.
    The license which you purchased is presumably of a permanent nature, and as
    such, there should be an ongoing obligation on their behalf to continue
    supporting any users who are experiencing such problems (assuming of course
    that such users actually possess a valid license).

    I'm not totally certain whether it's true, but I still think that it would
    be (technically) possible for them to issue you with another license number
    which would unlock *just* the schematic server (and on a permanent basis),
    and that you could simultaneously continue using the license number which
    they have already issued to you in order to unlock all of the other servers.
    (But if that is not actually true though, and they are unable to provide you
    with satisfactory assistance in order to unlock the schematic server using
    your existing license number, then they should be required to provide you
    with a new license number which unlocks all of the servers.)

    While I have never seen any of the source code which is associated with
    analysing license numbers and enabling (/ unlocking) the different servers,
    I still have reason to believe that some parts of that code can make "low
    level" changes to data stored on hard drives, in order to enforce time
    limits on licenses of a temporary nature (which are provided to people in
    order to permit them to evaluate the software during a trial period, and
    prior to actually purchasing it). In the cases of licence numbers which are
    supposed to enable one or more servers on a *permanent* basis though, the
    server(s) concerned *should* always be enabled, and regardless of any "low
    level" data which might ever have been written to the hard drive during any
    occasion.

    Having said that, Altium's software is notorious because of a "near enough
    is good enough" attitude, and a frequent unwillingness to investigate the
    fine details of how to implement features and functionality properly. And as
    such, it wouldn't surprise me in the slightest if there are actually bugs
    within the code for analysing licence numbers and enabling the different
    servers which can sometimes result in even license numbers of a permanent
    nature malfunctioning in some circumstances...

    In any event, good luck in your quest to regain the use of the schematic
    server on your new PC.

    Regards,
    Geoff Harland.

    (Transpose m & s in address
    provided - then also remove
    cuberoot of 10^3 + 9^3 - 1^3.)
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-