Connect with us

Problems with EPROMS

Discussion in 'Microcontrollers, Programming and IoT' started by bill999, Nov 10, 2011.

Scroll to continue with content
  1. bill999

    bill999

    8
    0
    Nov 10, 2011
    Hi All,
    I'm totally new to these forums, so please be gentle with me :)

    I am trying to write data to an eprom but I am not having much success. I have done this successfully in the past with my Genius NSP programmer.

    I tried a couple of days ago and everything was good. I was writing a 16kb file to a 27C256 eprom and it all worked fine. Then I wanted to write something else, so I erased it in my UV eraser and now the programmer fails straight away when I try to write even though the software tells me it is blank. I have tried a couple of other eproms I have and I get the same results. I thought it may be bad eproms. So I got a couple more from eBay - this time 27C128 as I am only writing 16kb. However, these eproms will not erase. If I read the data off of them, I see 256bytes of 0xFF, then 256bytes of 0x00. This pattern repeats.

    So I have 2 problems.
    1) I cannot write anything as it fails straight away
    2) I cannot erase my 27C128's

    Can anyone offer any ideas?

    Thanks
    Bill.
     
  2. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,499
    2,839
    Jan 21, 2010
    See if you can beg, borrow, or steal another programmer. (perhaps not steal it)

    Or try reinstalling the software for the programmer on another PC first.

    It's easier to imagine a single fault with the programmer or the software than simultaneous failures of all your eproms.
     
  3. bill999

    bill999

    8
    0
    Nov 10, 2011
    Thanks for replying.

    I tried reinstalling the software. I also cleaned all of the contacts on the ZIF connector.
    Still have the same problems.

    However, I found an old 2764 that I CAN program, so this suggests that my programmer is ok and that all 4 of the other eproms I have are bad. Which annoys me, because I only bought 2 of them from eBay a couple of days ago (used, not new).

    Its strange that the 2 'new' eproms have this wierd repetative pattern on them after erasing. (2048 bits of 1, then 2048 bits of 0, repeated). I could believe that they are bad eproms if the pattern was more random.

    Is it possible that a corrupt one could fail to erase in such a strange uniform way?

    Also, do you think it is worth doing a longer erase. I initially tried on 10 mins, then added 10 mins each time it failed until I was erasing them for 40 mins. So each one has been in the UV eraser for 1hr 40 (albeit not in one session).

    I always have this thought that 'cooking' them for too long in the eraser can damage them (or is this an incorrect thought?)

    Thanks for your help,
    Bill.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
Loading...
Electronics Point Logo
Continue to site
Quote of the day

-