Connect with us

Problem with SHT75 Humidity/Temperature Sensor

Discussion in 'Electronic Basics' started by Sensorboy, Dec 14, 2004.

Scroll to continue with content
  1. Sensorboy

    Sensorboy Guest

    Hello Sir,

    I am using a SHT75 humidity sensor. I am interfacing SHT75 with the
    MSP4301232 Microcontroller. The problem I am facing is - after writing the
    control byte; the SHT75 does not acknowledge proper receipt of control
    byte. I have verified the timings and found them to be good enough. I have
    also tried connecting a pull up resistor for the data line, but the SHT75
    does not drive the data line low.

    I am sending you a snapshot of the CRO display without the pull-up
    resistor. Here the data line is low after transmission of the control
    byte, but the data line is low after the Microcontroller release the pin
    and not by the sensor. I would appreciate if you could explain the problem
    behind this.

    Also, if you give me some idea of how I would test my Humidity sensor, I
    would appreciate.

    Regards,
    Krishna
     
  2. deyaya

    deyaya

    1
    0
    Mar 28, 2010
    Dear Krishna ,

    I have the same project for my final diploma at University " Politehnica" in Bukarest. Could you be so kind to help me and provide me the schematic ?

    Many thanks in advance,

    Deyaya
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-