Connect with us

Problem with SD card

Discussion in 'General Electronics Discussion' started by SkyAnthrax94, May 2, 2016.

  1. SkyAnthrax94

    SkyAnthrax94

    4
    0
    May 2, 2016
    I'm new here, so I'm not sure if this belongs here, but here's the issue I've been having: My phone reformats my SD card. I know how it sounds. Sometimes it just says the SD card is damaged, I take adapter, plug it into a computer and it's in an unknown format (a3x435hm7..... I googled it....it just....doesn't exist). So after it, even computer won't accept it.
    // The weird thing is it won't even format in windows after this happens. I have to log with my linux to be able to RAW format the card in the first place, so I can restore SD to it's defaults in the windows later on. Now this is a bit time consuming, and I really hate that I can't really even use the card, because I know in 3-4 days stuff is gonna be deleted anyway. Does anyone know what the problem might be? And how do I fix it?
    P.S. the card works fine with every other device. my phone is Alcatel One Touch M Pop OT-5020D (I know it's lame)
     
  2. Alec_t

    Alec_t

    2,700
    715
    Jul 7, 2015
    Welcome to EP!
    If the card works fine elsewhere that suggests the problem is with the phone rather than the card itself. I'd return the phone if it's still under warranty.
    Have you tried a different card in the phone?
     
    davenn likes this.
  3. SkyAnthrax94

    SkyAnthrax94

    4
    0
    May 2, 2016
    Um yeah, I tried a couple of other ones, the phone is not under warranty, and I'm short on budget, however I am good with manipulating software to my liking. I was hoping someone might help me reconfigure my phone?
     
  4. Ratch

    Ratch

    1,044
    308
    Mar 10, 2013
    Those cards have a speed rating. If you don't have one that is fast enough, you will run into probs. The speed should be marked on the card. I believe they go from slowest to fastest as marked by 2, 4, 6, 8, 10 and U. U stands for "ultra".

    Ratch
     
  5. donkey

    donkey

    1,286
    56
    Feb 26, 2011
    ok so if I am reading this right when you put the card in its ok. then phone does something, then sd card no work. then sd card in Linux to format and all good?
    in that case try erasing apps and factory reset your phone (this will erase everything so make copies first)
    it could be as easy as a game or something has corrupted your OS
     
  6. SkyAnthrax94

    SkyAnthrax94

    4
    0
    May 2, 2016
    That was the first thing I tried mate.
     
  7. SkyAnthrax94

    SkyAnthrax94

    4
    0
    May 2, 2016
    Just checked, card is compatible with the phone...
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-